iMessage issue...

Discussion in 'iOS 5 and earlier' started by Chuchichan, Jan 19, 2012.

  1. Chuchichan macrumors 6502

    Joined:
    Jul 17, 2010
    Location:
    Maryland
    #1
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    Recently I've noticed that I cannot initiate iMessage chats. I have been able to previously. I live in Japan and purchased my iPhone here.

    For example, my wife also has an iPhone on ios5 and before i would see he blue bubble icon next to her number when I search for her name in the "to" field. But now I have to start a conversation as a text message. When she replies it switches to iMessage.

    I noticed that I can fix this issue by going into Contacts and changing her phone number to international format (adding a "+81" in front of the number). However, I don't think I should have to do this as it worked before.

    Perhaps I made some change somewhere in settings, but I can't seem to be able to find it.

    Possibly on a related note, all of my Contact addresses are in Japanese format. I thought before I had them in both Japanese and US formats. I'd like to be able to have addresses and phone numbers in the format of the country for which that person lives.

    Thanks in advance for any help...
     
  2. Kyotoma macrumors 68000

    Kyotoma

    Joined:
    Nov 11, 2010
    Location:
    Carnegie and Ontario
    #2
    I've never had this issue, but then again when I do iMessage telephone numbers all of my contacts already have the international format added. Then again, I live in the US and I only have iMessaged US numbers, but they still have the "+1" in front of the area code.

    You could try a reset of your network settings, or even before that simply toggling iMessage off under Settings>Messages and then performing a soft reset and then turn iMessage back on.
     
  3. Chuchichan thread starter macrumors 6502

    Joined:
    Jul 17, 2010
    Location:
    Maryland
    #3
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    It's strange. I tried toggling, but no change. I can initiate iMessage chats with us contacts. In my address book they do also have the +1 in front of the phone number. However, I can't initiate with Japanese contacts unless I put the +81 in front of their phone number. But I shouldn't have to do this.

    One additional note is that under settings --- phone --- my number, my phone number is listed with a +81 in front of it and I cannot change this...
     
  4. SaSaSushi macrumors 68040

    SaSaSushi

    Joined:
    Aug 8, 2007
    Location:
    Takamatsu, Japan
    #4
    Is your iPhone with Softbank or Au? I'm with Softbank and I have had none of the issues you're experiencing. Also, my number under Settings > Phone simply begins "090" with no +81.

    The only setting I specify for my contacts (under Settings > Mail, Contacts, Calendars > Contacts) is Sort Order and Display Order of Last, First. For my contacts, the address format changes according to the country specified.
     
  5. aziatiklover macrumors 68030

    aziatiklover

    Joined:
    Jul 12, 2011
    Location:
    8.8.8.8 and 8.8.4.4
    #5
    settings>general>international>japan instead of united states. The area code will change to the country assign to.
     
  6. SaSaSushi macrumors 68040

    SaSaSushi

    Joined:
    Aug 8, 2007
    Location:
    Takamatsu, Japan
    #6
    I have all settings there to English and region format USA and the area codes work fine by simply setting the country per contact as previously mentioned.
     

Share This Page