iPhone iMessage Issue

Discussion in 'iOS 6' started by JamesOK, Sep 20, 2012.

  1. JamesOK macrumors member

    Joined:
    Mar 18, 2012
    #1
    Hi there.
    Since upgrading to iOS 6, I receive texts sent by myself which are directed to my wife. We both share the same iTunes account. How can I prevent from receiving my own texts? It's really annoying.
    Thank you.
     
  2. aarmstrong27 macrumors regular

    Joined:
    Jun 20, 2012
    #2
    One of two ways:
    1. Log out of iMessage on one or both of your devices.
    2. Create a separate apple ID for one of you to use for iMessage. You can still both use the same iTunes account for purchases, you will just have separate Apple IDs for iMessage (and iCloud too, which would be ideal).
     
  3. JamesOK thread starter macrumors member

    Joined:
    Mar 18, 2012
  4. parish macrumors 65816

    parish

    Joined:
    Apr 14, 2009
    Location:
    Wilts., UK
    #4
    I was just about to post asking the same thing!

    I don't understand. If you use a separate Apple ID for iCloud then doesn't that mean that you won't be able to automatically d/l new purchases via iCloud?
     
  5. aarmstrong27 macrumors regular

    Joined:
    Jun 20, 2012
    #5
    No. If you have two devices with the same Apple ID for iTunes, and all have "Automatic Downloads" checked, all apps and songs should still be accessible across devices.
     
  6. Errk! macrumors 6502

    Joined:
    Mar 6, 2006
    #6
    You can have multiple email addresses associated with you iCloud/iMessages account and enable specific ones for specific devices.

    For example, I have my phone number and email address and my wife's phone number and email addresses associated with my iCloud account. On my phone I have it set up with my phone number and email address and on hers it has hers. Also, on my iPad I have it set with my email address, and her iPad has hers. That way you don't have to worry about separate app purchases and each persons messages stay separate.
     
  7. parish macrumors 65816

    parish

    Joined:
    Apr 14, 2009
    Location:
    Wilts., UK
    #7
    Ah, thank you, I didn't realize you could associate multiple e-mail addresses with a single iCloud account.

    And that works even if one of the e-mail addresses is your Apple ID?

    I'll have another play with this then as I must have done something wrong. I tried sending an iMessage from my iPhone to my wife's iPhone and it appeared not only on her phone but also my MBP, her MBP, and "her" iPad.
     
  8. Errk! macrumors 6502

    Joined:
    Mar 6, 2006
    #8
    Yes. Mine is my Apple ID.

    If you are running iOS6 go to Settings>Messages and it will give you a list of the email addresses associated with your iCloud account. A check mark indicates which are associated with the device you're on.
     
  9. parish macrumors 65816

    parish

    Joined:
    Apr 14, 2009
    Location:
    Wilts., UK
    #9
    Thank you! :) That's what I've got wrong. When you add an e-mail it displays "Verifying" then, once verified, it shows a check mark. I didn't realise that you could uncheck it - I thought that the checkmark just indicated the address was verified. This is one minor annoyance for me with iOS. In that type of dialogue there is a different action depending on whether you tap on the blue arrow or in another part of the box.
     
  10. Errk! macrumors 6502

    Joined:
    Mar 6, 2006
    #10
    No problem. Yep, I can see not getting that. I might not have gotten it either except that I restored from my iPhone 4 backup so it had the list already filled and the appropriate IDs checked.
     

Share This Page