iMessage issue.

Discussion in 'iOS 7' started by Southernboyj, Sep 25, 2013.

  1. Southernboyj macrumors 68000

    Southernboyj

    Joined:
    Mar 8, 2012
    Location:
    Mobile, AL
    #1
    So I've been using an iPhone 5 running iOS 7.

    Today, I switched to a Galaxy S4.

    However, even when I text someone.. they're reply thinks I'm still using an iPhone, so it sends it as an iMessage.

    The result is all my text messages to iOS users getting pushed to my Mac/iPad and not my phone. Anyone know a fix for this?
     
  2. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #2
    Go back to the iphone? :p

    Honestly, I don't know how long it will take for people's iphones to realize you're not an iphone.
     
  3. Southernboyj thread starter macrumors 68000

    Southernboyj

    Joined:
    Mar 8, 2012
    Location:
    Mobile, AL
    #3
    Ahaha. I like the iPhone and I actually enjoy iOS 7. I just have a love for Android.
     
  4. apb89 macrumors regular

    Joined:
    Aug 25, 2012
    #4
    Go and change your Apple ID password. It will effectively log you out of iMessage on your devices.
     
  5. sbailey4 macrumors 68020

    sbailey4

    Joined:
    Dec 5, 2011
    Location:
    USA
    #5
    Or simply log out of iMessage if you still have the device. Maybe change the iMessage delivery to your email address not phone #
     
  6. cubelodyte macrumors newbie

    Joined:
    Sep 26, 2013
    #6
    Get recipients to send fresh message

    It may be simply that your iPhone send people messages using the iTunes ID rather than your phone number. If that's the case, when people respond, that's what they are responding to.

    I suspect that if they create new messages to your phone number, the issue will be resolved.
     
  7. Jon-PDX, Sep 26, 2013
    Last edited: Sep 27, 2013

    Jon-PDX macrumors regular

    Joined:
    Oct 20, 2011
    Location:
    Pacific NW - USA
    #7
    The odds are you have your Mac and iPad setup to receive text msg's at your phone number. Go into settings on the Mac and iPad and remove your phone number from the list that people can send msg's to.

    If you still want to receive iMessage's on those devices you will need to have an email address setup. Which most likely is already setup as your Apple ID. But you can use any email address you want.

    Jon...
     

Share This Page