iMessage issue

Discussion in 'iPhone' started by Serban, Oct 23, 2014.

  1. Serban Suspended

    Joined:
    Jan 8, 2013
    #1
    Today for no reason my iMessages are sent from my mail address instead of number. And im told that they are mixed, some of them from my number and some from my mail...

    Anyone else ?
     
  2. noobinator macrumors 603

    noobinator

    Joined:
    Jun 19, 2009
    Location:
    Pasadena, CA
    #2
    Just remove your email address and the problem should be solved.
     
  3. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #3
    iMessage issue

    It's annoying you need to be told that. I've had that happen plenty of times.

    Make sure in message settings that, start new conversation is from your phone number.

    You can also deselect the email address its using but keep in mind sms text forwarding won't work if you do that.

    ----------


    This will disable text forwarding. As long as they have no other apple devices they want SMS on then that is the best solution.
     
  4. Serban thread starter Suspended

    Joined:
    Jan 8, 2013
    #4
    not an option because i will no longer receive messages sent from other members that are sending through mail address.

    ----------

    Until today no issue at all so...my number is by default

    ----------

    I tried to uncheck my mail address and my imessages are no longer send with a red bubble "Not delivered"

    So probably thats why ...what can it be?

    I press on the "Not deliverd" send as text and after that it came back on normal...weird. Now everything its back to normal

    ----------

    but now i can't send a text message from my mac....

    ----------

    i don't find anymore text forwarding

    ----------

    i close settings app...and its back again.
     
  5. Y2JDMBFAN macrumors regular

    Joined:
    Sep 18, 2007
    #5
    As nice iMessages can be, I have them disabled, because I switch between Android and iOS enought that people with iPhones inevitably send me messages that I never get when I am on Android...
     

Share This Page