iMessage issue.

Discussion in 'iOS 9' started by bigpoppamac31, Jan 19, 2016.

  1. bigpoppamac31 macrumors 68000

    Joined:
    Aug 16, 2007
    Location:
    Canada
    #1
    So on my iPhone I have iMessage turned off and has been for a while. Yet I can't text one person cause it asks me to re-enable iMessage. Why would this be? I've texted others with iPhones with no problems. Thing is I got a message this morning from this one person and it came up on my Mac but not my phone. So I guess I had iMessage enabled on my Mac. But when I go to reply on my phone it won't let me unless I turn iMessage back on. How do I fix this so iMessage is off?
     
  2. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #2
    Does that "one" person have a cellular account, and is it enabled, or are they just using wifi?
     
  3. bigpoppamac31 thread starter macrumors 68000

    Joined:
    Aug 16, 2007
    Location:
    Canada
    #3
    Yeah they have a cell data account and also wi-fi.
     
  4. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #4
    I think it's because you have iMessage activated on the Mac and not on the phone. Both are signed into the same iCloud account, and it's creating a conflict. I bet that the contact in question has been selected as iMessage on the Mac. In the messages app, select the message on the Mac, and then place your cursor on the name next to the word "To", and I bet that is blue not green. Select the down arrow, and it should show that contact as an iMessage contact.

    Just curious...Why do you have iMessage off on your phone.
     
  5. bigpoppamac31, Jan 19, 2016
    Last edited: Jan 19, 2016

    bigpoppamac31 thread starter macrumors 68000

    Joined:
    Aug 16, 2007
    Location:
    Canada
    #5
    Personal preference. Either way it's annoying seeing as others I know who have iPhones show up as regular text message while one person doesn't. On my Mac I turned off iMessage and there's no message threads. I deleted those.

    EDIT: So I re-enabled iMessage on my Mac and the person in question shows up blue as you mentioned. But also another person does as well and he no longer has an iPhone. Another shows up red and he has an iPhone but no data plan. BTW I'm on El Cap and iOS 9.

    EDIT 2: It must have happened since I switched to iOS 9 about 2 weeks ago. Weird thing is I have texted the person since the switch with no issue but I've had iMessage turned off long before upgrading to iOS 9. But I tried to reply to him this morning and got the message asking me to turn on iMessage. The bubbles are blue going back about two weeks before switching to green bubbles.
     

Share This Page