iMessage issues on iOS8, anyone else?

Discussion in 'iOS 8' started by dictoresno, Sep 20, 2014.

  1. dictoresno macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #1
    ever since loading iOS8, I've been having random issues with my iMessage. on my phone i receive using my phone number and email, on my computer via email only and iPad via email only. handoff on all 3 devices are OFF. every now and then, i keep getting iMessages from my wife on both my iPad and my phone as if they were sent via email address. she said she's sending it via number, and i know it is since I'm the one starting the conversation from my phone which is set to send as my number. we don't share an apple ID, she was home on wifi with my iPad near, i was at work so i don't think its a wifi/handoff issue. it seems like iMessage is randomly messing up. I've switched iMessage off on both devices and back on again to see if it helps.

    on a side note, i was having a conversation with phone numbers with a coworker via phone numbers on our phones and he said one of my messages, mid conversation, came in under a different convo as my email address sent it. is there an iMessage bug where it decides to switch the caller ID from number to email? i don't need all of these messages ending up unnecessarily on my iPad.
     
  2. dlmart2 macrumors 6502a

    Joined:
    Nov 2, 2007
    #2
    On your device: Settings > Messages > Send & Receive
    On your Mac: Messages > Preferences

    Make sure all devices have the same accounts checked, and the 'start new conversations from' settings has the same email/phone number - usually phone number.
     
  3. dictoresno thread starter macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #3
    this was the first thing i checked....

    iphone is set to receive on number and email, send as number only
    ipad is set to receive email only and send as such
    imac is set as email only as well

    sometimes it just randomly switches up in mid conversation. i messaged my wife last night from work from my number. when i got home, my iPad and iMac had the whole conversation on it, which it shouldn't. they are properly set up to email address only. this morning i switched iMessage off on both and back on again, hopefully it reset this issue.
     
  4. dlmart2 macrumors 6502a

    Joined:
    Nov 2, 2007
    #4
    Yea, sounds like a bug. When I got my iPhone 6 and set it up, I had this issue but after I changed the settings I no longer had a problem.

     
  5. HeadphoneAddict macrumors 6502a

    HeadphoneAddict

    Joined:
    Sep 16, 2007
    #5
    I'm having the same issue with iOS 8, and turning off iMessage and back on doesn't help.

    I have confirmed the devices are set to use the right caller ID, and rebooted, and even swapped SIMs between two devices. Still, a few iMessages have made it through as coming from my email.

    I am NOT creating a new conversation, but rather replying to one that was formerly using my phone number as iMessage caller iD. And, now that I have two phones and both are set to iMessage from the primary number, the other phone ALWAYS sends as if from the other phone's number.

    On my devices all the iMessages are in one conversation as they should be - BUT on my wife's device (as the recipient) she has some of the iMessages in one conversation as coming from my number, and some iMessages in another conversation as coming from my email. (and now from the wrong phone number, the other phone)

    After I started using two phones, even though both are set to send iMessages from my primary phone number (not the number that used to belong to my iPad), they ALWAYS arrive on everyone's device as if coming from the second new phone (formerly my iPad number).

    So, if I swap SIMs between the iPhone 6 and 6+, whichever one has the new phone SIM wont send iMessages with the old primary number. Turning off iMessage and rebooting, and turning it on last night didn't help.

    So, while 99% of the time I can reply from my iPad Air and it looks like my phone and 1% of the time it comes from my email, 100% of the time when I reply from the new phone it doesn't look like it came from the old phone like it should, it comes from the new phone's number.

    That should only happen with SMS but nit iMessages.

    PS: My son just told me that he sometimes has this happen when he sends an iMessage from his iOS 6 iPad Mini, and even though iMessage should show it came from his phone number it shows up at the other end from his email.

    WE DON'T EVER SHARE OUR APPLE ID with anyone, so as to only use it with apple and not get spam, and Apple is sharing our Apple ID randomly via iMessage with people we don't want to share it with.
     
  6. philly33flyers macrumors newbie

    Joined:
    Jul 14, 2008
    #6
    Same Issue

    I have the same issue you speak of and in addition, a lot of times I don't even get messages or the sender gets the "Message could not be delivered" error message even though I'm in clear coverage area. In addition, I restarted my phone one day and got about 4 SMS messages from 2 days prior that I had never before received.

    I never had any issues prior to iOS 8 and getting the new 6+. I tried turning iMessage off and back on. I've tried turning off, reset network settings, and turning back on. It's still random, my wife still gets messages from my icloud email instead of my phone number randomly.

    Chatted with apple support and they claimed only solution was to do a full reset on phone (which loses all settings) or to do a restore and then recover from icloud backup.

    Both of these solutions are a pain as I don't want to lose my settings and I think it's a waste of time to have to restore your phone and then wait for all apps, music, photos to re-sync back to device.

    Anyway, I'm glad I'm not the only one with this issue. Keep us updated if you ever solve it.
     
  7. Swampbaby985 macrumors member

    Swampbaby985

    Joined:
    Nov 25, 2013
    Location:
    East Texas
    #7
    Lately Iv've keen getting messages from one friend that has been coming through from his email address. All of his messages beforehand was coming from his phone number. Also I get the "message send failure" alert when I clearly have service.
     
  8. sbailey4 macrumors 68040

    sbailey4

    Joined:
    Dec 5, 2011
    Location:
    USA
    #8
    Had similar issue with it randomly changing. One solution is to remove email address from the iP (just uncheck it seems to work) and only have number in there. Can always re-select email again if you want a particular message to use email address. This seems to be a work around at least until its resolved via an update.
     
  9. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #9
    That is an issue from your friend's side - he needs to make sure his settings are to begin conversations from his phone number and only add messages to that thread. If he posts them in the email thread, it will continue to say from his email.
     
  10. kappaknight macrumors 68000

    kappaknight

    Joined:
    Mar 5, 2009
    #10
    I've noticed this as well. I'm in a group message with other iOS 8 and iOS 7 people, and the conversations are popping up in all sorts of different places. Sometimes a single reply will start a new thread, other times it jumps back in the same thread. Just the other day at&t decides to send me an email every time an SMS was posted, no idea why.

    Very annoying indeed.
     
  11. Meathead1 macrumors member

    Joined:
    Oct 28, 2014
    #11
    Add me to the list of people having this issue.
     
  12. Geckotek macrumors G3

    Geckotek

    Joined:
    Jul 22, 2008
    Location:
    NYC
  13. JPS127 macrumors member

    Joined:
    Oct 23, 2013
    #13
    My bug is that badges no longer appear on the iMessage icon. I get a sound alert, but no visual indicator. And, yes, I've done all the right things others have suggested.
     

Share This Page