iMessage Jail

Discussion in 'iOS 7' started by nREMfan, Aug 10, 2014.

  1. nREMfan macrumors member

    Feb 10, 2010
    I'm looking to switch to Android after being with the iphone since day 1. However, each time I follow the steps to "turn off" iMessage on my iphone, iPad and Mac - iphone users can no longer text me.

    Those that have switched, how long did it take for your number to get "released"? I don't want to miss anything for a client that uses an iphone. Did the process accelerate by calling Apple?

  2. Neverbepeace macrumors 6502a


    Jan 14, 2009
    New York
    I usually turn it off 2 days before getting a non apple phone.
  3. tbayrgs, Aug 11, 2014
    Last edited by a moderator: Aug 12, 2014

    tbayrgs macrumors 603


    Jul 5, 2009
    I never had problems deactivating iMessage and continuing to get text messages from iPhones, was near instantaneous as far as I could tell--and I've switched back and forth a few times. Supposedly disassociating your mobile number from your Apple ID helps (login online and manage settings from there).
  4. Oohara, Aug 11, 2014
    Last edited by a moderator: Aug 12, 2014

    Oohara macrumors 68020


    Jun 28, 2012
    OP, I've had trouble with this too. Several people were not able to sms me for about a month, and with one particular friend it took nearly two months for some reason.

    Like tbayrgs says you need to disassociate your number from imessage, and turn the service off, in ios settings. Either online or on an iPhone. Additionally, I had to log out of iTunes, iCloud, everything, and create new passwords for all of them, then log back in and finally it took hold.

    I'm not sure exactly which of all these things finally freed my number from imessage, if you Google it you will find a whole gaggle of solutions but as I said it took me two months and finally worked when I had read the solution about new passwords and logging out, and tried that.

    Good luck!
  5. nREMfan, Aug 11, 2014
    Last edited by a moderator: Aug 12, 2014

    nREMfan thread starter macrumors member

    Feb 10, 2010
    Using Google is a myriad of trouble and "solutions". It's a shame Apple has made it this way.
  6. SpyderBite macrumors 65816


    Oct 4, 2011
    Make sure the people who are messaging you are using your phone number rather than your email address. Once an imessage is sent via the email addy it will become the default going forward.

    Have somebody with a non-iOS device text you and see if that goes through.
  7. soulreaver99 macrumors 68020


    Aug 15, 2010
    Southern California
    You need to logout and disable your iMessage accounts on all your devices and tell your friends who have iPhones to delete all their old iMessage threads with you.

    Another thing you need to check is My Apple ID. Login to and make sure that your Icloud account isn't associated with your phone number. This was the one thing that kept me stuck on iMessage for a few years and I couldn't figure it out!

    And finally, call Apple Tech Support and have them disassociate your phone number with iMessage, this works with most people.
  8. mattopotamus macrumors G5


    Jun 12, 2012
    Everything these two said. It is insane how difficult it can be to turn off imessage.
  9. lysola macrumors member

    Aug 12, 2014
    A related question that I think I made up in my own head... but are iMessage and 4G/wifi at all connected? There are times in the past where I've disabled iMessage and had all my internet connectivity off as well, and I noticed that it took messages from fellow iPhone users a LONG time to reach me. Sometimes hours, sometimes days. Since then, I've just left iMessage on, but I've always wondered if this was actually the case or not.
  10. C DM macrumors Westmere

    Oct 17, 2011
    They are connected in the sense that iMessages will use data, but that's about it.
  11. GoSh4rks macrumors 6502

    Sep 14, 2012
    iMessage will ONLY use data. If you have no internet connectivity, iMessage cannot work.
  12. lysola macrumors member

    Aug 12, 2014
    Thank you and CDM. I figured this was the case, but it's good to know for sure. I've kept iMessage on ever since, but I do notice that sometimes my texts will be delayed or give me errors when I try and send them once in awhile and turning off 4G and Wifi for 2 minutes and then re-enabling them usually does the trick. Sometimes it's iMessage at-large, but as I said.. good to know.
  13. iolinux333 macrumors 68000

    Feb 9, 2014
    99% of this iMessage BS would go away in a week if Apple would just open source it so we could debug it and port it over to other platforms. Apple has clearly demonstrated, over the course of YEARS that they do not have the talent in-house to make it work correctly.

Share This Page