iMessage keeps turning off

Discussion in 'iPhone' started by MrMister111, Oct 20, 2013.

  1. MrMister111 macrumors 68020

    Joined:
    Jan 28, 2009
    #1
    I have a 5s with iOS 7.02 on. Everyday now my iMessage is turning off by itself.

    I only realise when I go into a message to an iPhone user and it's not blue. Check settings>iMessage and it's off. I turn it on and it works again - so annoying. Does anyone else have this?
     
  2. R.Stoychev macrumors 6502a

    R.Stoychev

    Joined:
    Dec 23, 2012
    #2
    Reset your network settings and it should be working properly :rolleyes:
     
  3. itsmemuffins macrumors 68030

    itsmemuffins

    Joined:
    Jun 23, 2010
  4. MrMister111 thread starter macrumors 68020

    Joined:
    Jan 28, 2009
    #4

    I reset network settings a while ago after installed iOS 7 as iMeaasge was on but wasn't working. That seemed to fix that, but now iMessage keeps turning off.

    I don't play candy crush so not sure what you mean.

    Thanks
     
  5. MacDaddy22 macrumors newbie

    Joined:
    Sep 2, 2010
    #5
    Have the same issue on my moms phone. It also seems to be the source of the following problem:

    Usage time and standby time are the same. When the phone is in standby, there seems to be an issue with iMessage that's causing the phone to do stuff while it's asleep. Reset network settings and it works for a while, then goes back. Any help would be appreciated.
     
  6. MrMister111 thread starter macrumors 68020

    Joined:
    Jan 28, 2009
    #6
    Mine seems to be sorted now with the newest update of v7.0.3, is everybody's else's?
     
  7. Irishnerd macrumors newbie

    Irishnerd

    Joined:
    Jun 20, 2016
    #7
    .

    I have the same problem and I've done everything people have suggested. I have an iPhone 4S and I don't know why it's like this.
     
  8. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #8
    I would restore with iTunes and setup as new.
    It's a software bug.
     

Share This Page