iMessage login message

Discussion in 'Mac Apps and Mac App Store' started by davidlv, Apr 7, 2018.

  1. davidlv macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #1
    Since updating to 10.13.4, I keep getting a "lSign in to iMessage" but the Apple ID password it asks for is from an ISP I used years ! ago, and I don't remember that password, or use that Apple ID at all.
    How can I get rid of that pop up message? imessag.png
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    Try opening iMessage then command-comma to get to preferences, then in the Accounts tab select the account and click the minus at the bottom to remove it.
     
  3. davidlv thread starter macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #3
    Thanks for the reply. I tried that, but the problem account doesn't show up at all in the list.
    Where is that info 0 in some plist file? (that ISP is at least 8 years old btw). I will try searching for it.
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    Hmm... how about in Keychain? Anything in there from that account you could delete?
     
  5. davidlv, Apr 11, 2018
    Last edited: Apr 26, 2018

    davidlv thread starter macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #5
    Tried to delete any keychains with that ISP inside, but couldn't find any. So I did some house cleaning and deleted several really old keychains. That seems to have worked as I haven't seen that strange error message after a reboot. I suspect your suggestion was valid! Thanks again.
    Edit with more info:
    My MacBook Pro 2011 had the same issue, but I coudn't solve it the same way.
    So I simply copied the User/Library/Keychain folder from the Mac Pro to the laptop. and rebooted.
    Had to enter an iCloud password and voila, no stupid iMessage message!
    So yes, definitely the issue was an out-of-date keychain, maybe an invisible item.
    Thanks again for the suggestion, which led to resolving this strange but annoying issue!
    :cool::D:cool:
     
  6. davidlv, Apr 26, 2018
    Last edited: Apr 30, 2018

    davidlv thread starter macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #6
    I added an edit to my last post, having some success in getting rid of that annoying popup message from the message app on reboot, and then I tried to open the accounts tab in the preferences of the message app again. I swear it had no account listed when I did that the first time, but now it has that old Apple ID account listed! I cannot delete that account, it just won't do it. However, there is a check box for "Enable this account", which I immediately turned off, so now that account is not active. Tried to set up a new (modern) account and that new account gets set to a default type labeld "Jabberer". Sounds like a line from a Star Wars spin-off! :confused:
    But it still won't let me delete the original old Apple ID account.
    Now that annoying pop-up message does not appear, so we're closer, but somehow I get a log-in "password please" screen on wake from sleep on the MacBook Pro only. Where did that come from? I finely found the preference for that in the Security preference pane and turned that off.
    I also used Onyx to delete all of the caches and reboot.
    I am sure I should eventually do a clean install, but the thought gives me shudders, as it would take a whole day at least, and just to get rid of an old non-existent Apple ID in the Message preferences, doesn't sound worth it.:oops:
    One more edit:
    Eventually, considering that this computer is an older model, and I use it only as a backup machine, I reverted to an archived CCC backup of Sierra, 10.12.6, which seems rock solid. At least it has no "Jabberer" episode!:cool:
     

Share This Page