iMessage, Message & inconsistent iCloud integration

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by Carl Sagan, Jul 29, 2012.

  1. Carl Sagan macrumors 6502a

    Carl Sagan

    Joined:
    May 31, 2011
    Location:
    The Universe
    #1
    Putting this here as it's about the connection between iMessage and Messages...

    Anyone finding the new Messages in OS X10.8 a little... unwieldily? So far if I get an iMessage on my iPhone 4S it doesn't show up on my Messages. But if I start a message to someone else's iPhone in Messages it shows on my iPhone and theirs. Now here's the annoying bit, if I start a message on Messages and then continue via iMessage on my iPhone the recipient gets two different message threads to deal with!

    I thought messages and iMessage was going to be a bit more slicker than this given all the i Cloud hype...
     
  2. boogs84 macrumors newbie

    boogs84

    Joined:
    Jul 27, 2012
    Location:
    Cleethorpes, United Kingdom
    #2
    I'm having the same problems, and to be honest its starting to annoy me. I've tried searching the web for solutions but their doesn't seem to be any yet... oh well maybe its a bug that needs fixing.
     
  3. Carl Sagan thread starter macrumors 6502a

    Carl Sagan

    Joined:
    May 31, 2011
    Location:
    The Universe
    #3
    I'm hoping this is a bug and not just how it works because like you it's become annoying real fast.
     
  4. Gemütlichkeit macrumors 65816

    Gemütlichkeit

    Joined:
    Nov 17, 2010
    #4
    First trouble shooting step is to make sure your caller ID is set to your Apple ID and make sure your Apple ID is present in your settings on OSX.

    I'm having these issues even after double checking both are the same.
     
  5. Carl Sagan thread starter macrumors 6502a

    Carl Sagan

    Joined:
    May 31, 2011
    Location:
    The Universe
    #5
    Yup all that is the case for me. Still getting this issue...
     
  6. hafr macrumors 68030

    Joined:
    Sep 21, 2011
    #6
    1: It's because that message was sent to your phone number, and not your Apple ID. Messages for OS X can't receive messages sent to a phone number. Known limitation that will be fixed with iOS 6 in the merger of phone number and Apple ID.

    2: It's because you're sending from your Apple ID, meaning the answers will be sent to it, syncing across your devices.

    3: Known issue. My guess, the only logical answer to this question, is that received messages in iOS are divided by a device specific ID from the sender, and not by contact. Hopefully this will be fixed in iOS 6, but I haven't heard anything about it.

    To solve what can be solved, make sure you have the same Caller ID (your Apple ID e-mail address) set up on both your phone and in Messages and tell your friends that have iMessage to only send messages to your Apple ID e-mail address and not your phone number.

    iOS: Settings > Messages > Receive at > Caller ID
    OS X: Messages > Preferences > Accounts > iMessage > Caller ID
     
  7. Carl Sagan thread starter macrumors 6502a

    Carl Sagan

    Joined:
    May 31, 2011
    Location:
    The Universe
    #7
    Ok cheers, this is a bit clearer, thought I'd set up iMessage on my phone to go to my Apple ID, now done. Will tell my primary contacts to do the same.
     

Share This Page