iMessage name confusion

Discussion in 'iOS 5 and earlier' started by LastLine, Oct 15, 2011.

  1. LastLine macrumors 65816

    Joined:
    Aug 24, 2005
    #1
    When sending a message to my wife using iMessaging (as opposed to direct SMS messaging) it shows on her phone as being from herself - is this an iCloud thing?

    Anyone else come across this/no what to doa bout it?
     
  2. techfreak85 macrumors 68040

    techfreak85

    Joined:
    Jan 13, 2008
    Location:
    Places
    #2
    Are both of you using the same Apple ID for iMessage?
     
  3. LastLine thread starter macrumors 65816

    Joined:
    Aug 24, 2005
    #3
    I guess so. Is there a way to set that so that it does one or iMessage and one for iCloud?
     
  4. BmoreDrumGuy macrumors regular

    Joined:
    Mar 12, 2010
    Location:
    Baltimore, MD
    #4
    You can enable that in messages settings.
     
  5. Steve28 macrumors member

    Joined:
    Jun 14, 2011
    #5
    Settings->Messages->Receive At

    There you set what email addresses can be used to message your phone. Then under "Caller ID" you selected which one of those will appear as the "from" in messages you send.
     
  6. LastLine thread starter macrumors 65816

    Joined:
    Aug 24, 2005
    #6
    Ok got it mostly sorted. Only thing is my wife's phone allows her to receive at her phone number. Mine doesn't. Anyone know how to add my mobile number in?
     
  7. FranzMarc macrumors member

    Joined:
    May 11, 2010
    #7
    Hhmm that's odd, for me my phone number is default in there and greyed out, I can't actually change/remove it from iMessage.

    Do you have your caller ID hidden, could that have to do with it? o.0

    Btw how do you iMessage someone on an iPod touch (with ios5 and iMessage turned on) if the only thing you get when entering a contact in the Message app are phone numbers?

    I seem to not be able to enter an email address there. Although the same person can iMessage me from their iPod touch.
     
  8. LastLine thread starter macrumors 65816

    Joined:
    Aug 24, 2005
    #8
    I forget off hand where to check my caller ID - but it shows up in the same greyed out way as you describe, in Facetime, so I suspect not.
     
  9. LastLine thread starter macrumors 65816

    Joined:
    Aug 24, 2005
    #9
    Have you got their email set in their contacts entry? That might help if not.
     
  10. FranzMarc, Oct 16, 2011
    Last edited: Oct 16, 2011

    FranzMarc macrumors member

    Joined:
    May 11, 2010
    #10
    Yeah I do. It works if I either copy/paste the Email/Apple ID from contacts into Messages or click on "Message" directly in the Contacts App. Still seems a bit clumsy if it does not show up in Message as an option to pick from the contacts.

    About the phone number...I read somewhere that a) the phone number has to be associated with the Apple ID. Basically if I check on https://appleid.apple.com/ and Manage your account, then Phone Numbers it shows my mobile number.

    If thats the issue then you might have to log out of the apple ID and/or offline iMessage on your iPhone to make it work?
     
  11. LastLine thread starter macrumors 65816

    Joined:
    Aug 24, 2005
    #11
    Just to answer my own Question:


    If you get a phone where the phone number doesn't show up in iMessage simply turn iMessage off for 15/20 minutes, make sure you're in phone signal, and turn it back on. This forces a reactivation of the iMessage system which picks up your number and email addresses together.

    It appears to be caused by your number not being immediately active when setting up iMessage.
     

Share This Page