imessage needs to be enabled to send this message

Discussion in 'iOS 8' started by macgrl, Dec 11, 2014.

  1. macgrl, Dec 11, 2014
    Last edited: Dec 11, 2014

    macgrl macrumors 65816

    Joined:
    Jul 17, 2008
    #1
    is what i get when i try to send a text to my brothers iphone. He has imessage turned off on his phone.

    I have imessage turned off on my iphone when I want to send him a text as it goes to his ipad (which has imessage turned on)

    I just want to send him an sms message but I can't as i get this message.

    why can't it go through as an sms text? like it would on a normal phone?
     
  2. afsnyder macrumors 65816

    Joined:
    Jan 7, 2014
    #2
    iPads don't have SMS texting. The only way that would work would be through
    Continuity.
     
  3. macgrl thread starter macrumors 65816

    Joined:
    Jul 17, 2008
    #3
    Thank you for your reply. I am trying to send an sms from my iphone to my brothers iphone. With imessage turned off on my iphone I am met with that message and cannot send an sms
     
  4. Agent-P macrumors 68030

    Agent-P

    Joined:
    Dec 5, 2009
    Location:
    The Tri-State Area
    #4
    imessage needs to be enabled to send this message

    If you're brother wishes to keep iMessage enabled on his iPad but not his iPhone, have him uncheck his phone number for iMessage on the iPad.

    He can do that at "Settings > Messages > Send & Receive" and just remove the check mark next to his phone number and your texts should start going through as sms.
     
  5. NoBoMac macrumors 6502a

    Joined:
    Jul 1, 2014
    #5
    Ok, I'm officially confused re: the suggestion to remove the phone number on brother's iPad.

    With Messages going back and forth on Apple devices via iCloud, the phone numbers should not enter in the equation. It's worked for me before iOS 8 on my wi-fi only iPad, whether or not the message was sent as phone number or other address. And Mac. As long as I'm messaging with another Apple device user, all is good.

    So, first, sounds like OP needs to enable Messages to be able to send anything. Brother can have the phone number set for iPad (as well as on Mac if he has that). Everyone needs to be logged into iCloud. After all that, the Apple servers will do the mapping of numbers and addresses and ring the devices that have Messages enabled. After that, brother can have his cellphone Messages turned off and messages will go to the iPad no problem and not the phone.

    As long as he's got the iPad on iCloud and Messages on, can send to his iCloud ID as well, if want to make sure not sending to phone number.

    Now, if for some reason can't contact Apple's Messages servers, then will not send anything since sounds like his iPad is wifi only.
     
  6. sbailey4 macrumors 68030

    sbailey4

    Joined:
    Dec 5, 2011
    Location:
    USA
    #6
    I think no one is understanding the request. His brother does not have iMessage enabled on phone for whatever reason. He DOES have it on iPad so gets the iMessage there. OP trying to send SMS to iPhone and get the message that iMessage needs to be turned on.

    So never seen a message indicating that imessage had to be on. I would look in setings>message and make sure SMS is enabled. That should allow SMS if iMessage is off. Also make sure you are sending from and to the phone numbers not the email addresses registered. So on your end send from number is selected and sending to is his number not email. Maybe even uncheck the email in message (have seen that cause weird issues before of recent) and just have phone number in there.
     

Share This Page