iMessage needs to be enabled?!

Discussion in 'iPhone' started by AppleHater, Mar 8, 2015.

  1. AppleHater, Mar 8, 2015
    Last edited: Mar 8, 2015

    AppleHater macrumors 6502a

    Joined:
    Jun 9, 2010
    #1
    I've been using iMessage to send photos to fellow iPhone users and other cell phone users. Now I get I need to have iMessage enabled to send messages.

    It looks like I can't send MMS to other non iPhone users.

    iMessage has been enabled all along I have no clue what the f&$@ is going on. Can someone help me figuring this problem?
     
  2. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
  3. T5BRICK macrumors 604

    T5BRICK

    Joined:
    Aug 3, 2006
    Location:
    Oregon
    #3
    Disable and re-enable iMessage.
     
  4. AppleHater thread starter macrumors 6502a

    Joined:
    Jun 9, 2010
    #4
    I did it with no luck.:(
     
  5. HenryDJP macrumors 603

    Joined:
    Nov 25, 2012
    Location:
    United States
    #5
    iMessage being activated does not prevent the iPhone from sending MMS to other non-iPhone users. Try a reboot or if all else fails then back up your phone and do an erase and install.

    But maybe your username is finally catching up with you and Karma has now taken over. ;)
     
  6. adock macrumors newbie

    Joined:
    Jul 21, 2014
    Location:
    PA
    #6
    Check the settings and see if you have mms enabled when imessage isn't available.
     
  7. rockitdog macrumors 68020

    Joined:
    Mar 25, 2013
  8. maritroyd macrumors newbie

    Joined:
    Aug 10, 2015
    #8
    I think iMessage needs Wifi to work, at least on T-Mobile.
    That happened to me today after I had just sent an iMessage to another iOS user.
    I think iMessage turned off cuz it was using cellular data (I was in car (not driving)) and no Wifi. When I got home the iMessage was fine.
     
  9. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #9
    I'm with T-Mobile. My iPhone is always on cellular and so is my iPad. I get iMessages just fine and they get forwarded to my iPad just fine.
     
  10. timeconsumer macrumors 65816

    timeconsumer

    Joined:
    Aug 1, 2008
    Location:
    PNW
    #10
    While iMessages can be sent over WiFi, they can also be sent over cellular data if WiFi isn't available as per: https://support.apple.com/en-us/HT201287 it says "If Wi-Fi is unavailable, iMessages will be sent over cellular data. Carrier cellular data fees might apply."
     
  11. M5RahuL macrumors 68020

    M5RahuL

    Joined:
    Aug 1, 2009
    Location:
    Colorado
  12. marf1million macrumors regular

    Joined:
    Jul 23, 2013
    Location:
    An Mhí
    #12
    Did you take the SIM card out of your phone at all? Whenever I remove the sim card, even for 10 seconds, I need to reenable iMessage. Also you need to have some credit on your account for it to activate because the phone sends a text messages to your carrier to enable it.
     
  13. DevelopingZack macrumors newbie

    Joined:
    Mar 8, 2015
    #13
    I know this is a late answer for you, but I hope it helps someone else...

    I got the same message today when sending pictures in a group text where some of the participants where not iPhone users.

    I found that the error message appears when I tried to send multiple images in the same message. Sending them 1 by 1 worked without the error.
     
  14. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #14
    That's false.
    iMessage doesn't need wifi.
    It sends over carrier data and on tmobile carrier network.
    And no it doesn't turn off when away from wifi and turns back on when you're gone and connect to wifi.
    Your whole post is full of fail.
     
  15. Rockitman macrumors newbie

    Rockitman

    Joined:
    Sep 21, 2017
    #15
    Not quite. I have the same problem,and a few others, and am about ready to throw this piece of a phone under a bus.
     
  16. Italianblend macrumors 68000

    Italianblend

    Joined:
    Mar 21, 2011
    Location:
    Fatima
    #16
    You're holding it wrong. Hahahah ok that was a good one.

    Should be automatic. Maybe take to Apple Store. They are pretty reasonable about malfunctions.
     
  17. maerz001 macrumors 6502

    Joined:
    Nov 2, 2010
    #17
    Even when this is a year old.
    My solution was to delete the chat history
     

Share This Page