iMessage not activating

Discussion in 'iOS 5 and earlier' started by Mach2001, Mar 9, 2012.

  1. Mach2001 macrumors newbie

    Joined:
    Oct 7, 2011
    Location:
    UK
    #1
    Not sure if I am just being dumb, do I need to be connected to wi-fi to turn imessage on or should it activate automatically as I am trying over 3g and it just says 'Verifying' and then tells me there has been an error.:confused:
     
  2. Collin789 macrumors regular

    Collin789

    Joined:
    Mar 29, 2011
    Location:
    Greensboro, NC
  3. Arelunde macrumors 6502a

    Arelunde

    Joined:
    Jul 6, 2011
    Location:
    CA Central Coast
    #3
    Do you have iMessage turned on in Settings > Messages? Also in the same setting location, do you have you iPhone set to receive iMessages on your phone number AND email? That might make a difference.
     

Share This Page