iMessage not available, phone grayed out?

Discussion in 'iPhone' started by noobinator, Oct 14, 2014.

  1. noobinator macrumors 601

    Joined:
    Jun 19, 2009
    Location:
    Los Angeles, CA
    #1
    I used an iPhone for years and then switched to android recently and had a heck of a time getting messages from my contacts iPhones to reach me. There phones were trying to send imessages instead of SMS.

    Finally, i removed my number from my apple support profile and text the word STOP to 48369 per instructions I found online. SMS worked for the most part.

    Now, I went BACK to an older iPhone and when I am trying to use iMessage. I re-added my number to my apple profile. When I go into settings on my iphone under messages, then send and receive, it shows my email address and my phone number. I unselected my email but my phone number is grayed out and I can't select it.

    So it seems like I cannot send iMessages from my iPhone using my phone number. I do not want to use my email. Anyone know why my number would be grayed out?
     
  2. wxman2003 Suspended

    Joined:
    Apr 12, 2011
    #2
    Does the "Start New Conversations From" in Messages show your number with a check mark?
     
  3. noobinator thread starter macrumors 601

    Joined:
    Jun 19, 2009
    Location:
    Los Angeles, CA
    #3
    Ok, i turned off imessage and restarted my phone.

    Now my phone number shows up and has a check but it still is only sending SMS and not imessages.
     
  4. wxman2003 Suspended

    Joined:
    Apr 12, 2011
    #4
    Are you sending text to another person with an iPhone? It only works between iOS devices.
     
  5. noobinator thread starter macrumors 601

    Joined:
    Jun 19, 2009
    Location:
    Los Angeles, CA
    #5
    of course I am.
     
  6. wxman2003 Suspended

    Joined:
    Apr 12, 2011
    #6
    Ok, i was just checking. I know of others who couldn't figure out why it wasn't working. Some had issues because they were sending a text to multiple people. If one in that line doesn't have an iOS device, it will automatically default to a regular text. Have you tried resetting network settings? you may have to do a restore.
     
  7. PMehta macrumors regular

    Joined:
    Oct 30, 2012
    #7
    It could be 'cos of the STOP text that you sent. I've never heard of texting a number to stop iMessage but checking if this is the cause might fix it.
     

Share This Page