iMessage not being sent via phone number?

Discussion in 'iOS 8' started by Macuser360, Sep 19, 2014.

  1. Macuser360, Sep 19, 2014
    Last edited: Sep 19, 2014

    Macuser360 macrumors newbie

    Joined:
    Sep 13, 2014
    #1
    I restored my 6 from my 5's backup and it obviously loaded all of my iMessage conversations on my new device. Now I have people telling me that my messages are showing up as being sent from my iCloud account and not my cell number (they only have the cell in their contacts, so my full email is showing up.)

    Weird thing is, none of the settings in Messages have changed, and my phone is correctly set up to automatically send from the phone number by default. It's obviously not doing that...has anyone else experienced this or found a fix?

    EDIT: Restoring network settings did NOT work...that was recommended on another post.
     
  2. willydimes macrumors regular

    Joined:
    Jun 8, 2014
    #2
    yea just had the same issue, i went to my phone, turned on one of the email addresses and then went back to laptop and logged back into iMessage and it worked then i just went back and turned off the email address on my phone.(i only use iMessage on my number)

    If that doesn't work just fiddle with it, turn something on or off on the phone and it should correct itself
     
  3. platoaddict macrumors newbie

    Joined:
    Sep 12, 2014
    #3
    I had that problem as well. Actually, with both iMessage and FaceTime. I turned each off then reenabled them. Before selecting took use AppleID, I waited until phone number was selected. Problem solved.
     
  4. techishi macrumors member

    Joined:
    Jan 26, 2013
    Location:
    US
    #4
    Happened to me before I did a cold boot, reset my network settings, and then re toggled iMessage & FaceTime.
     
  5. Photography macrumors 65816

    Photography

    Joined:
    Apr 10, 2007
  6. bigchrisfgb macrumors 65816

    Joined:
    Jan 24, 2010
    #6
    It happened to me where it reverted to using my email address. I turned off my email address and the option to use my number was still greyed out. I turned my phone off and on and it automatically reverted to using my number.
     

Share This Page