iMessage not delivered/sending from email w/ SMS fowarding

Discussion in 'iOS 8' started by exalted719, Oct 21, 2014.

  1. exalted719 macrumors member

    Joined:
    Sep 29, 2008
    #1
    Whenever I lose reception then regain it later (ie, undergroun), my iMessages do not send properly. When I send messages, my friends tell me they are coming from my Apple ID rather than my phone number.

    I tried fixing this by unchecking my email in "Send and Receive". With this, I just get iMessage "not delivered" whenever I send a message after losing reception. To fix this, I must send an SMS first, then the subsequent iMessages are sent as iMessages successfully.

    As some of you may know, you must have your email checked to have SMS forwarding to work. But now that I have my email checked again, my iMessages are being sent from my Apple ID rather than my phone number whenever I come out of the subway.

    Anyone encounter these problems and know how to fix? I'd love to continue to use SMS forwarding but it requires me to check my email address, which causes my iMessages to send from my Apple ID with no way for me to tell, other than my friends telling me my iMessages are glitching.
     
  2. ser968 macrumors member

    Joined:
    May 18, 2008
    #2
    this is happening to me too - all of the sudden, my texts are being sent from my email despite having my phone number checked as the 'start conversations from option' option in imessage. my temporary solution is to uncheck all of my emails as 'can be reached by' options.

    I don't like doing this because then my other devices don't get my texts either! I suspect that this is a bug that will need to be addressed in 8.2
     
  3. Ledgem macrumors 65816

    Ledgem

    Joined:
    Jan 18, 2008
    Location:
    Hawaii, USA
    #3
    I hope it will, but I wouldn't expect it. The glitches with a device suddenly switching over to sending through your email address instead of your phone number has been going on for as long as iMessage has been around. It's what led many of us to disable email addresses for use with texting in the first place :(
     

Share This Page