iMessage not sending pictures

k6578

macrumors member
Original poster
Jun 23, 2012
42
2
This began around two weeks ago.. I've been unable to send any pictures via iMessage. It would show a red "not delivered" alert every time. Regular text is working fine.

I updated to the newest iOS 7.1.1 today and still can't get pictures to send at all. On my iPhone 5, I've tried resetting all network settings and turned my phone on/off.

This is also a problem on my Macbook Air, can't get pictures to send either. There'd be no red "not delivered" alert and appears to have sent successfully, only the recipient never receives the picture.

:confused:

Any one else experiencing this?

Thanks!
 

k6578

macrumors member
Original poster
Jun 23, 2012
42
2
Are you using carrier data or connected to a particular wifi network when those imessages wont send out?
Test out both instances to see if it send one way or the other or fails for both.
I've tried both carrier data, as well as various wifi networks at home and school.
 

k6578

macrumors member
Original poster
Jun 23, 2012
42
2
Nothing?
Weird, I'd try a restore and setup as new and try again.
Do text imessages go through? Just picture imessages dont?
Ok I just tried a restore.. erased everything on the phone and set it up as new with my iCloud backup. I still have the problem.

Yep, text iMessages sent from both iPhone and Macbook Air go through. Pictures do not, from both devices.
 

PM-Performance

macrumors 6502
Feb 12, 2012
320
47
I had this problem the other day with mine. I reset the settings and turned imessage on and off and it seemed to have fixed mine.
 

xanderbear

macrumors newbie
Jul 12, 2008
6
0
Napa
Its been happing to me and many of my friends. When you send a picture via iMessage you get an error stating that the picture didn't send. However the picture has actually been sent. Even a friend of mine in Australia had the same thing happen to him yesterday when we were texting. Its incredibly annoying. :mad:
 

rajpatel

macrumors regular
Feb 23, 2013
145
0
I've experienced the erroneous "pic not sent" message or whatever it says but also sometimes while I'm typing it will insert a random pic from my photo album in the message which is annoying but not a big deal but a hassle on that tiny little keyboard. I will never have a small phone after this one again. The design is beautiful but it is maddening to use as anything other than a phone, music player, and camera.
 

Outrigger

macrumors 68000
Dec 22, 2008
1,760
93
same thing has happened to me as well. thought it was an imessage outage, but guess its more than that.
 

Cole Slaw

macrumors 6502a
Oct 6, 2006
960
1,474
Canada
The wife has a 5C and sends (or tries to) pictures with iMessage.
I notice when she sends one picture it usually works fine, but sending multiple pictures seem to trip iMessage up somehow.
 

k6578

macrumors member
Original poster
Jun 23, 2012
42
2
Oh great, more problems. Now I'm noticing that when people send me images via iMessage, I get them on my MacBook Air only and not my iPhone. :confused:
 

lehrblogger

macrumors newbie
Mar 7, 2010
9
6
Detroit suburbs
Are you sure there's enough disk space for the photo on the recipient's iPhone?

I was having a similar problem – Messages would take a long time to send the photo, and even say "Delivered" underneath, but then change to the red "Not Delivered" and tell me to try again. Non-photo messages would go through fine. I tried disabling and enabling iMessage on both devices, but that didn't seem to help.

But then, when I tried to take a photo to send in the other direction, it gave me a storage error! I freed up some space on the recipient's device, turned it off and on again, and when I tried again the photo went through :)
 

BigDukeSix

macrumors 6502a
Sep 22, 2010
718
0
34.6700N 118.1590W
I've also had this problem. Latest OS on my iPhone 5, sending to another iPhone /ipad. Both using wifi and LTE. MMS enabled. The person I sent the pics to did say they would display initially then disappear. Anyone found a solution?
 

mRta03

macrumors newbie
Aug 17, 2012
24
0
I'm having this error for months. I try to send a picture with iMessage (either cellular or wifi) and keeps giving the same red warning with not delivered but people keep receiving them anyway.

More annoying: After sending an image through iMessage, it's delivered, and then, 3/4 hours later, it says: "the Message could not be delivered to ...". But the person already saw it. It's VERY annoying.

Is this happening at iOS 8.1?
 
Last edited:

Fantasigraphic

macrumors 65816
Mar 25, 2009
1,291
82
TN
Are you guys on Verizon by Chance? I had a buddy on Verizon (ip5) who was having same problem. I turned off iMessage/FaceTime rebooted via holding Home + Power then I went back and turned both Imessage and FaceTime and let them activate. NOT saying this is a fix but something you can try

Ok I just tried a restore.. erased everything on the phone and set it up as new with my iCloud backup. I still have the problem.

Yep, text iMessages sent from both iPhone and Macbook Air go through. Pictures do not, from both devices.
Your restoring from backup so you'll still have this problem!

Restore and setup as NEW. And see. Don't use iCloud backup.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.