iMessage not syncing with phone since iOS8

Discussion in 'OS X Mavericks (10.9)' started by 5to1, Sep 24, 2014.

  1. 5to1 macrumors 6502

    Joined:
    Mar 9, 2008
    #1
    Since I upgraded my iPhone and iPad to iOS8, iMessage on my Mac no longer syncs with the iCloud account used on those devices.

    I checked the account under "internet accounts" and there is now no longer an iMessage option to tick, and so it doesn't appear under "accounts" in iMessage. That obviously explains why its not syncing with my iphone/ipad but not sure what to do to fix it. I've tried deleting the account of the Mac and entering it again, but same result.

    The only possible problem I've noted is my account is an @me.com account. On my iPhone/iPad I now see both a @me and @icloud account with the same name listed (and ticked) under iMessage/FAcetime. But under the iCloud account settings its the @me.com account thats signed in.

    I tried adding the @icloud account as well on my Mac, but it just said its already signed in and took me to the @me account of the same name.
     
  2. 5to1 thread starter macrumors 6502

    Joined:
    Mar 9, 2008
  3. NoBoMac macrumors 6502a

    Joined:
    Jul 1, 2014
    #3
    No problems. Working fine. But then again, my AppleID is tied to a different e-mail account, and I don't use any @icloud or @me.

    So, sounds like you've got the same buttons that I've got checked. Can be contacted at AppleID and my iPhone number. I've got "initiate threads from" set as my phone number.

    It shouldn't matter from my understanding, but maybe try this: logout on all devices from iCloud. Relogin via the @icloud id instead. Reconfigure if needed. What with @me being "old" and @icloud is Apple's current preferred addresses, might be some weird error going on translating old @me addresses to @icloud, which might be what the core of iCloud services are working on/with.

    Just a WAG.
     
  4. jmj macrumors member

    Joined:
    Jun 8, 2009
    #4
    I'm having the same issue. My phone number isn't tied to my iMessages account in Mavericks 10.9.5 anymore.
     
  5. 5to1 thread starter macrumors 6502

    Joined:
    Mar 9, 2008
    #5
    Thanks for the reply guys.

    I have been thinking about trying to switch all devices to the @icloud account. Just been hesitant as I rely heavily on syncing between devices, key chain etc. So in case it messes something up (small chance I know), i only want to do it on a relatively free day.

    I suspect it is going to be something to do with me using the @me account. As the App Store account I share with the family is also on my laptop, it's from my own domain (so not an Apple email account), and that appears under iMessage. For that account I also get the option to link the number of the phone that uses it as its primary account aswell under iMessage. Whereas my @me account doesn't appear under iMessage at all:/
     
  6. 5to1 thread starter macrumors 6502

    Joined:
    Mar 9, 2008
    #6
    Tried switching to the @icloud account and no joy. Worse still it didn't pick up my keychain passwords so had to switch back to the @me account quickly (heart in mouth moment as really didn't need hassle of recovering passwords)
     
  7. 5to1 thread starter macrumors 6502

    Joined:
    Mar 9, 2008
    #7
    Totally at a loss what to do now:

    1) If I look at my @mydomain iCloud account, I can see the option to use it under OSX iMessage and also bind the mobile number associated with that account.

    2) Neither my @me or @icloud accounts show up under iMessage

    3) I have to login via @me account or I don't see my Keychain passwords on OSX.

    Getting pretty annoying as have become very used to picking up my messages on my laptop :/
     
  8. 5to1 thread starter macrumors 6502

    Joined:
    Mar 9, 2008
    #8
    Ok, its a bit embarrassing but I figured it out.

    I had the following iCloud accounts under "internet accounts":

    5to1@me.com (iCloud account used on my devices)
    5to1@mydomain.com (iCloud account used on my wifes devices, but also shared for App store)
    .........
    .........
    <other non iCloud accounts> (Google accounts/etc)

    But under iMessage I could only see:

    5to1@mydomain.com
    .........
    .........
    <other non iCloud accounts> (Google accounts/etc)

    I was assuming the way accounts worked under iMessage was the same as under "internet accounts". Therefore was trying to figure out why iMessage hadn't also picked up my 5to1@me.com account.

    In fact iMessage has one entry for iCloud accounts and within that you choose which account to sign in to. It doesn't as I thought pickup iCloud account details from "internet accounts" based on if you have iMessage ticked. What probably made me think this was how it worked was that the 5to1@mydomain.com account had this box ticked, whereas the 5to1@me.com account didn't even list this box :/

    Hope this helps someone else and that it makes some sense to readers :/
     
  9. cable0guy macrumors newbie

    Joined:
    Dec 8, 2012
    #9
    Not sure if I understand you. My messages don't sync either since I bought an iPhone 6. All my accounts are logged in via @me

    Seems like a bug to me.
     
  10. cable0guy macrumors newbie

    Joined:
    Dec 8, 2012
    #10
    I got mine to work. I had to reset my Network Settings. And then in Messages Settings, I inputed Apple ID. That fixed it.
     

Share This Page