iMessage Not Syncing?

Discussion in 'iOS 5 and earlier' started by ghsNick, Jul 2, 2012.

  1. ghsNick macrumors 68030


    May 25, 2010
    So I have my iPad and iPhone synced up to a tee.
    Anyways, Whenever I start conversations (iMessages) from my iPhone it doesn't go through to my iPad. But when I start a conversation from my iPad it goes across to my iPhone too.

    Basically, I'm just wondering if all conversations are deleted is the only way to get iMessage conversation across iPad and iPhone by starting it on the iPad?
  2. macslayer118 macrumors 6502

    Oct 6, 2008
    Dallas, TX
    Probably has to do with your iPhone using the phone number to send iMessage and the iPad uses the email address, which is also associated with the phone. Works one way, but not the other. Associating phone number and email together for iMessage is a "feature" of iOS6.
  3. CosmoPilot macrumors 65816


    Nov 8, 2010
    South Carolina
    Wirelessly posted

    A temporary fix for now is to change your caller ID on your phone to your Apple ID. then when others respond to your messages, they will be responding to that Apple ID, thus both devices. The down side, others must know your Apple ID or they might. It know who the message is coming from
  4. Carlanga macrumors 604


    Nov 5, 2009
    is like macslayer said FOR NOW...

    When iOS6 comes out you will have no issues w/ this and your iMessages will be seen in all your Mac devices no matter if you are using your # or email addresses.
  5. Arelunde macrumors 6502a


    Jul 6, 2011
    CA Central Coast
    If you use your email address (not necessarily the Apple ID one) as your primary iMessage contact in Settings > Messages, the iMessages will show up on everything. However, I've noticed there may be a lag in messages showing up in the iPad compared to the iPhone.

    PS - I sure miss the beta Message app on my MBP. Really got used to it. I understand Mtn Lion will have it again. It worked very well with the iOS messaging.

Share This Page