iMessage not working between 2 iPhones only, others ok

Discussion in 'iPhone' started by MrMister111, May 29, 2016.

  1. MrMister111 macrumors 68020

    Joined:
    Jan 28, 2009
    #1
    For some reason iMessage between 2 people in our family isn't working, yet between others it is, from each of the affected iPhones as well. So it's only between 2 people it's not working between, so strange. Yet another iPhone can send iMessage to each fine?

    We've restarted both, switched off iMessage on each, put back on, force restarted, still won't work. Why/how can they both work for everyone else, just not between 2 specific people, so confused.

    Also normal sms text messages are a bit delayed sometimes as well. We are both on same network in UK, EE, good signal, phone calls are fine.

    Anyone help please
    Thanks
     
  2. mlemonds macrumors 6502a

    mlemonds

    Joined:
    Apr 9, 2008
    Location:
    Lexington, KY
  3. G.McGilli macrumors regular

    Joined:
    Oct 19, 2015
    #3
    OP: When you say 'not working' - what actually happens? Get error message saying not delivered? Or do they send and just vanish?
     
  4. MrMister111 thread starter macrumors 68020

    Joined:
    Jan 28, 2009
    #4
    Normally when you type the send is in blue. It's always in green now for this person, then seems as a sms (green) message, the same the other way. No error, just doesn't even start as an iMessage.

    Worked prefect until few days ago, send 10s of thousands of iMessage between each other.
     
  5. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
  6. MrMister111 thread starter macrumors 68020

    Joined:
    Jan 28, 2009
    #6
    Yes both the same, just us two though, to other up phone users it's fine, that's what is so strange
     
  7. rijc99 macrumors 6502a

    rijc99

    Joined:
    Apr 27, 2015
    Location:
    FEMA Region 9
    #7
    You say two people in your family... Different or same Apple ID?
     
  8. MrMister111 thread starter macrumors 68020

    Joined:
    Jan 28, 2009
    #8
    Two people in same family yes, separate Apple ID, but use family sharing for apps etc.
     
  9. pdxmatts macrumors 65816

    pdxmatts

    Joined:
    Jan 12, 2013
    Location:
    Portland, OR
    #9
    Settings>General>scroll to the bottom Reset>Reset Network Settings
     
  10. MrMister111 thread starter macrumors 68020

    Joined:
    Jan 28, 2009
    #10
    Well, done absolutely nothing more than above on last post, and now it's suddenly working.

    What is going on? So strange, only between 2 specific iPhones, to and from those iPhones to other iPhones and worked fine?

    Must have been something on Apple side, however it worked on some, which is the strange thing
     

Share This Page