iMessage not working between 2 iPhones

Discussion in 'iPhone Tips, Help and Troubleshooting' started by greg55, Jan 25, 2014.

  1. greg55 macrumors newbie

    Joined:
    Jan 25, 2014
    #1
    My wife and I can't use iMessage between our phones since Thursday night. I've tried everything.

    -- turned on airplane mode on both phones to reset wifi
    -- turned off iMessage on both phones
    -- signed out of iMessage through Apple IDs then signed in. We login with my same email account but only use our phones for iMessages
    -- both phone iOS are updated
    -- restart of phones

    Any other tips? Driving me crazy. Thanks!
     
  2. Mrbobb macrumors 601

    Joined:
    Aug 27, 2012
    #2
    I get the feeling your callee has to be on your contact list?
     
  3. ugcop, Jan 25, 2014
    Last edited: Jan 25, 2014

    ugcop macrumors 6502a

    ugcop

    Joined:
    Mar 15, 2012
    Location:
    Traveling @ Warp Speed ...... USA
    #3
    Check settings / messages
    Be sure phone number on each device is checked
    Then
    Go to messages / edit : and delete all messages strings between your two phones
    Reboot each phone
     
  4. greg55 thread starter macrumors newbie

    Joined:
    Jan 25, 2014
    #4
    Yes. We're married! And no accidental deletions in contact lists.
     
  5. kenners, Jan 25, 2014
    Last edited: Jan 26, 2014

    kenners macrumors newbie

    Joined:
    Jan 11, 2008
    #5
    I seem to have the same problem. Went to local AT&T and he told me to turn off iMessage. Seems like AT&T would benefit financially if I turn off iMessage. But that is the only way I can presently text my wife. Greatly appreciate any info. :)

    Doing post #3 worked - Thank You :)
     
  6. ugcop macrumors 6502a

    ugcop

    Joined:
    Mar 15, 2012
    Location:
    Traveling @ Warp Speed ...... USA
    #6
    follow the instructions in post #3
    That should fix it.
     
  7. greg55 thread starter macrumors newbie

    Joined:
    Jan 25, 2014
    #7
    Thanks! My wife deleted one message rather than all of them and it worked.

    So weird and buggy but glad it's fixed. Thanks.
     
  8. ugcop macrumors 6502a

    ugcop

    Joined:
    Mar 15, 2012
    Location:
    Traveling @ Warp Speed ...... USA

Share This Page