Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

stephg

macrumors regular
Original poster
May 14, 2010
140
41
This is driving me crazy so I hope someone can help. My husband and I both have iPhone 13s. Lately iMessage does not work between our 2 phones (it used to). It sends initially as an iMessage then changes to sent as text message a few seconds later. Half the time the messages do not show up on the other phone which is the real problem. So far I've tried:

turning off and then on the iMessage setting in Settings on both phones
unchecking and rechecking send and receive phone numbers
hard restart on both phones
checking both phones are on WiFi and cellular data
both phones are updated to latest iOS

I'm not sure if it's relevant, but we are on a T Mobile family plan.

iMessage works fine with everyone else that has an iPhone. It's only between our 2 phones that the problem occurs. Does anyone have any ideas why this is happening and what I can do to fix it? If we go to the Apple Store, would they be able to help? I can't find a way to schedule an appointment for this. None of the options fit and it just keeps redirecting me to articles that don't help. Thank you in advance for any ideas!
 

now i see it

macrumors G4
Jan 2, 2002
10,908
23,110
Try
Switch both iPhone 13s to wifi only. Then try.

Then try switching them to cellular only and see if anything changes.

When I moved to a new place with new internet service, there were certain things I could no longer do. I had to chat with the ISP and they reset something on my router or modem — and then I could do stuff normally again
 
  • Like
Reactions: stephg

stephg

macrumors regular
Original poster
May 14, 2010
140
41
Try
Switch both iPhone 13s to wifi only. Then try.

Then try switching them to cellular only and see if anything changes.

When I moved to a new place with new internet service, there were certain things I could no longer do. I had to chat with the ISP and they reset something on my router or modem — and then I could do stuff normally again
Okay, I will try this. Thank you!
 

stephg

macrumors regular
Original poster
May 14, 2010
140
41
Coming back to give the solution! First I should say I am the tech person in the marriage. My husband and technology are not friends. He also has arthritic hands that don't help. Well, it turns out he had somehow inadvertently blocked me! LOL And to give him his due, he was the one who accidentally figured it out when he also accidentally tried to do a FaceTime call to me and it said it was to a blocked contact. So then I looked through his blocked list and there it was. So it seems all fixed now. I spent so much time going through settings and turning on and off and deleting stuff. That really did not occur to me. So I'm posting this and maybe it helps someone else looking for answers. Thanks to those who offered help!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.