iMessage Not working for me. HELP!

Discussion in 'iPad' started by soamz, Oct 13, 2011.

  1. soamz macrumors 6502a

    Jun 20, 2010
    Orissa, India
    Updated my iPad 2 to iOS5 and everything is good, except iMessage.

    When Im trying to send iMessage to any email or phone , it doesnt let me click on SEND button.

    Also, few guys tried sending me iMessages from their iOS devices , but I dint receive any.

    In went to settings. Confused about it.

    See the screenshots :


    Why is it showing error ?
    And when I tried adding another email, it said, wrong ID and there is no option to delete email ? WTF ????

    Another question.
    How does it work ?
    Is it only iOS to iOS devices ? How would we know, who has iOS device , while sending message ?
  2. rodman109110 macrumors 6502

    Jun 7, 2007
    Not sure what's wrong on your end but as to your other questions it wont let you send anything from an iPad if the reciever doesn't have ios 5. On the iPhone it'll say text or iMessage where you type and it automatically checks if the receiver has ios5.
  3. soamz thread starter macrumors 6502a

    Jun 20, 2010
    Orissa, India
    Thats fine.

    But why Im not able to reply to messages or send the ones, with iOS devices and iMessage ?

    Why it says error on my settings page ?

    Did you check that screenshot.
  4. rodman109110 macrumors 6502

    Jun 7, 2007
    I did see your screen shots but I don't really have an answer. If you click where it says apple ID you can sign out and sign back in or sign in with a different apple ID email.

    I had the gm installed last week and it didnt work right away and I just restarted my iPad and it started to work for me.
  5. airjarvis macrumors newbie

    Aug 22, 2011
    Ran into the same issue with iMessage not allowing to send/reply to group. I went to Settings: Messaging and turned off all of the iMessage stuff and can now respond to my group messages.
  6. jjrec macrumors newbie

    Oct 14, 2011
    If your issue is that you cannot hit SEND, make sure that you're typing your message on the message line and not the subject line. I ran into the same problem too and realized that there are 2 lines (subject and message line). You do not need to fill out the subject line, but if you leave the message line empty, it will not let you hit send.

    Hope this helps.

Share This Page