iMessage not working for others on 5.1?

powrman811

macrumors member
Original poster
Oct 25, 2011
31
0
Under Messages (Settings>Messages) it says "Waiting for activation..."

I am on Wi-Fi and have a good 3G connection. Any ideas? I just restored last night and still no luck.
 

zefff

macrumors newbie
Jul 17, 2011
22
0
Canada
iMessage not working after 5.1 install on iPhone 4

iMessage is not working on wi-fi. I have a feeling it's because I have no service with my provider.
 
Last edited:

nburwell

macrumors 601
May 6, 2008
4,629
1,632
DE
After I updated to 5.1, I went to iMessage my girlfriend, and before I composed the message, the "send" button was green and the gray lettering said "text message." I did a soft reset on my phone and after that, I re-composed the message and it went through as a iMessage.
 

kurtmac

macrumors newbie
Mar 10, 2012
3
0
Minnesota, USA
Not Delivering Immediately

I've noticed a variation of this issue. That iMessage does not post the "Delivered" confirmation immediately (sometimes delayed for several minutes or hours) and the person I am sending the iMessage to, only receives it when I do see the confirmation.

Really wondering if this is an iMessage server issue or related to my SMS plan (200 messages) with AT&T (lower priority than someone having the unlimited plan??).

fyi, this is not happening consistently, but randomly. Sometimes it does show "Delivered" immediately, but other times, it does not. Odd!
 

noobinator

macrumors 603
Jun 19, 2009
6,388
5,364
Pasadena, CA
My wife upgraded her iphone 4 to 5.1 yesterday and every message she sends me (4s on 5.1) shows up as a text message. even when the phones are an inch apart on the same wireless network. any suggestions? I've tried rebooting etc...
 

asweetdee

macrumors newbie
Mar 12, 2012
1
0
Same issue

I have the same issue of not being able to consistently use iMessage. When I restart my phone, I can send and receive iMessages fine, but at any given moment within the next 30 minutes it screws up again and goes back to the green Text Message format. I've resorted to using TextPlus until this gets fixed.

Side note: I'm in France (have been for almost three weeks) and still paying for my monthly plan, so WiFi iMessaging was what I depended on for communicating home until I updated to iOS 5.1 yesterday.
 

rannddeee

macrumors regular
Jun 18, 2008
126
0
La La Land, CA
I wanted to send an iMessage but the send button stayed green. I went to settings and iMessage was turned off for some reason. I tried to turn it on but it said "activation failed" or whatever message it was. I tried multiple times throughout the day but was not successful. I did a restore last night and now it's working again. It sucks that I had to waste 1 hour restoring just to fix the issue.
 

mlmwalt

macrumors 6502a
Jun 8, 2010
548
1
Philadelphia, Pa, USA
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9B179 Safari/7534.48.3)

My fiancé is having the same issues too. I'm on Verizon & she's AT&T. My data connection gets all wonky when I have no wifi access. You'd think more people would notice these issues.
 

Bossyman

macrumors member
Oct 18, 2011
98
3
Here's what worked for me

1 turn off iMessage

2 power down by holding both buttons and don't let go until phone turns on again

3 turn on iMessage

4 wait for it to connect

5 did it to all phones on my account, my sons and girlfriends, cuz we were all getting each others messages

6 worked fine after that
 

manc

macrumors newbie
Mar 15, 2012
2
0
My wife upgraded her iphone 4 to 5.1 yesterday and every message she sends me (4s on 5.1) shows up as a text message. even when the phones are an inch apart on the same wireless network. any suggestions? I've tried rebooting etc...
Get your wife to send a message to her own number, she should get the message back straight away. Her imessage should now be working.

Do the same on your phone, then turn each phone off and switch back on.

Test messaging again, it should be fixed.

Had the same problem today and this fixed it

Edit: Make sure imessage is turned on and activated to the phone number of your phones.
 

spackletoe

macrumors newbie
Mar 15, 2012
1
0
Get your wife to send a message to her own number,
Edit: Make sure imessage is turned on and activated to the phone number of your phones.
I have had the same issue, and so has my wife, both a different times, and we both had our iMessage activated through our email address... the above step fixed us both.

I think it kinda sucks as a solution, but it works. My question then is how are people on desktops and ipads supposed to find us to use FaceTime? Hopefully as a secondary address, and I still have my "caller ID" as my email address.
 
Last edited:

manc

macrumors newbie
Mar 15, 2012
2
0
I have had the same issue, and so has my wife, both a different times, and we both had our iMessage activated through our email address... the above step fixed us both.

I think it kinda sucks as a solution, but it works. My question then is how are people on desktops and ipads supposed to find us to use FaceTime? Hopefully as a secondary address, and I still have my "caller ID" as my email address.
If your iMessage settings say you can receive at 2 addresses, one email and one you phone number, everything will work as normal. Just make sure your caller Id in settings is set to your phone number.

iPads will send to your email and iPhones will send to your number.
 

JUiCEJamie

macrumors 6502a
Mar 22, 2011
748
18
Hmmm... I've had the same problem. Strange!

I've been messaging someone who's still on 5.0.1 (I'm on 5.1) and we're having the same issue.
The problem being, the message says it's 'Not Delivered' yet, we're still receiving the messages.

I'll try turning off iMessage, then doing a restart etc etc.
 

fullojellybeans

macrumors regular
Mar 31, 2010
135
0
I've been having the same problem since updating to 5.1. iMessages will send as blue, I'll get "delivered" under it and then moments later it reverts to a green bubble and "sent as text" it's quite annoying. I believe the reason is due to the fact that there's no longer a "try again as text message" option and it's forcing the message out over text.

I had it resolved for about 8 hours and then when I woke up in the morning it was back to sending as text. I don't usually complain about iOS issues but this one is my biggest problem. Anyone try doing a DFU restore and set up as new?
 

zefff

macrumors newbie
Jul 17, 2011
22
0
Canada
This won't be very helpful, but to offer some hope to others, iMessage randomly started working on my iPhone 4.
 

cynics

macrumors G4
Jan 8, 2012
11,334
1,709
I've been having the same problem since updating to 5.1. iMessages will send as blue, I'll get "delivered" under it and then moments later it reverts to a green bubble and "sent as text" it's quite annoying. I believe the reason is due to the fact that there's no longer a "try again as text message" option and it's forcing the message out over text.

I had it resolved for about 8 hours and then when I woke up in the morning it was back to sending as text. I don't usually complain about iOS issues but this one is my biggest problem. Anyone try doing a DFU restore and set up as new?
I just had a failure to send a message and when I clicked on it it asked me to try again or send as text. Im using a 4S on 5.1
 

farkingdom

macrumors member
Mar 20, 2012
67
134
I faced iMessage problem when updating to 5.1, so after a little digging, my iMessage gets back to normal after doing a reset on the network.

Hope this helps.
 

RolandNights

macrumors 6502a
Aug 8, 2011
549
0
California
My brother has some issue, but ONLY when he texts me. The message gets really delayed, then sometimes it sends me two or three copies of the same message. Sometimes if he sends me a series of messages, they come in out of order.