iMessage not working in Messages

Discussion in 'OS X Mavericks (10.9)' started by megalaser, Jun 12, 2013.

  1. megalaser macrumors 6502


    Nov 17, 2009
    Installed Mavericks and noticed that my iMessages are offline, I see there is no option to set up iMessages in the message app (a phone number - for text messages) - anyone found a solution? Thanks
  2. Four oF NINE macrumors 68000

    Four oF NINE

    Sep 28, 2011
    Hell's Kitchen
    I posted in another thread that iMessages is there for me, but is asking for a password which isn't registering for unknown reasons.. not sure what's going on with that.
  3. shznit macrumors member

    Apr 4, 2010
    same issue here, says "could not sign in, please check your network and try again"

    I tried it with and w/o firewall.
  4. megalaser thread starter macrumors 6502


    Nov 17, 2009
    OK then so maybe I'm missing the fact that before the phone number field appears you need to register an iCloud account in there first, well it asked me for mine, I put in my correct login and password and I just get a spinning wheel.
  5. shznit macrumors member

    Apr 4, 2010
    Maybe I should have logged into iCloud before attempting iMessage, which still forwards SMS your phone receives. I skipped that step when 10.9 booted for the first time.

    Either way, they can't expect us to follow a particular sequence of logging into stuff.
  6. megalaser thread starter macrumors 6502


    Nov 17, 2009
    signing into Apple ID's to set up iMessage do not appear to be working in Messages in Mavericks.
  7. robertpolson, Jun 12, 2013
    Last edited: Jun 12, 2013

    robertpolson macrumors regular

    Feb 24, 2011
    Found the solution.

    1. Open iMessages

    2. Go to Preferences - Accounts

    3. Choose your apple ID email account and click enable this account

    I am not sure if I had this menu before turning in iCloud off and on again but this worked for me. iMessage now works on Mavericks and iOS 7.
  8. Baklava macrumors 6502a


    Feb 1, 2010
    I can't send and receive Messages via my mobile number. I'm logged in with my iCloud account but my mobile number is not listed under
    Messages > Preferences > Accounts > iCloud Account > You can reached for messages at.
    Any solutions so far?
  9. Kuwait macrumors member


    Apr 25, 2012
  10. Lance-AR macrumors 6502

    May 7, 2012
    Little Rock, AR
    I think this is one of the things some users will have to wait until DP2 or later to fix and then it will just start working.
  11. ValkyrieLenneth macrumors regular


    Jun 28, 2008
    My iMessage works fine. Try to be a little more patient at the spinning wheel after logging on the first time, guys.... It can take up to 5-10 mins.;)
  12. Distearth macrumors newbie

    May 6, 2008
    Worked for me

    This also fixed the "Send to iPhone" missing from Maps. I got the beach ball and waited a min. then killed it and reopened. Logged in and all is well.

  13. Tom359 macrumors regular

    Jul 13, 2007
    Same issue..iMessage is offline, and won't enable

    I've tried to enable my iMessage account, but that option is grayed out and not available. I tried logging out of iCloud, and logging back in, but once I log out it won't log back it at all. Keeps saying to try again later. Now my mail, etc. won't work. Currently doing a restore from Time Machine.
  14. gpsouza macrumors 6502


    Jan 1, 2012
    I'm having this issue with DP2, did you solve your problem?
  15. shznit macrumors member

    Apr 4, 2010
    DP2 did not solve it, but I didn't do a clean install.
  16. gpsouza macrumors 6502


    Jan 1, 2012
    I guess it was a problem with my number. I've changed my carrier and everything went normal again :)
  17. shznit macrumors member

    Apr 4, 2010
    that doesn't explain why it worked in 10.8
  18. scalp86 macrumors newbie

    Aug 10, 2013
    It is still not working for me, even with the newest beta. Still get the error message mentioned above... Any recomendations how to reset messages or sth?!:confused:
  19. asmedes macrumors newbie

    Aug 29, 2013
    not working for me either

    trying to sign in and it just spins and spins...
  20. Bzinetti macrumors newbie

    Oct 17, 2013
    Hey guys,

    I just figured out how to fix this issue, and it may work for you too. Here's what I did:

    Messages > Preferences > Accounts > your iCloud account tab

    Click "Add Email" next to "You can be reached for messages at:"

    Type in your phone number, hit Enter, and follow the instructions on the screen. It will involve configuring some settings on your phone.

    Hope this helps!!
  21. colinwil macrumors regular

    Nov 15, 2010
    Reading, UK
    Thanks - that worked :)
  22. castlema macrumors member

    Nov 21, 2003
    I am having a similar problem. Yesterday, when I upgraded to Mavericks everything worked fine. Today Messages does not work. When I put in the person's name it appears in red and I am told that I am not signed in to my iMessage account but when I go in to the preferences it shows that I am signed in. I have tried signing out and signing back in, restarting the computer and resetting the NVRAM. Messages is working just fine from my iOS devices and from my iMac but not from my Mac Book Pro. The iMac and the Mac Book Pro are on the same network.

    Any thoughts or suggestions?
  23. benji888 macrumors 68000


    Sep 27, 2006
    United States
    try going to:

    System Preferences>iCloud>

    or System Preferences>Internet Accounts>iCloud
  24. kevaquarian macrumors newbie

    Mar 29, 2011
    Hi. I had the same weird issue. Messages suddenly stopped working - asking me for the password, which it would not accept, and the spinning pinwheel was there forever.

    I tried a few things that have been suggested on various forums.

    After updating from Mavericks to Yosemite, the problem persisted.

    Finally, I tried resetting the PRAM but that didn't solve it.

    I was using Maps a few days ago, and wished to share a location to my phone. I went to the "share" option in the drop down menu, and saw that there was an option to use Messages to send it.

    I chose this option in case it would be another way in to Messages sign in etc. Long shot. Then came a prompt that said something like "no Messages account is configured" or similar. I followed the screen prompts and was presented with a login box. I entered my details and then couldn't believe it - Messages was up and running again on the Mac.

    I've no idea whether this will work on anyone else's system but thought I'd share it just in case it was worth a shot.

    No Messages on the Mac was really doing my nut in, as I use it regularly to transfer useful stuff quickly to the phone.

Share This Page

23 June 12, 2013