iMessage not working to one contact while FaceTime does - help!

Discussion in 'iOS 8' started by JonnyBlaze, Feb 3, 2015.

  1. JonnyBlaze macrumors regular

    Joined:
    May 5, 2008
    Location:
    UK
    #1
    I'm using an iPad3 and my wife has an iPad2 and iPhone4. Both iPads are on latest iOS8.1.3 and the iPhone is on iOS 7.1.2.

    When I use iMessage, I see all my available contacts in blue, and send to them all fine, apart from my wife; I can't send iMessages to her. When I put any of her registered emails into the 'to' field, they end up red, and when I try to delete them I get a message saying "address not registered, do you want to remove it". When she tries to send me an iMessage my contact name is blue but the message sometimes says "not delivered" and sometimes says "delivered" but never appears on my iPad.

    We can both make FaceTime calls to each other just fine.

    I have tried resetting network settings on all devices. I have tried signing out of iMessage, FaceTime, and icloud and then turned off the devices, before signing in to everything again but none of these things has helped. All services are turned on and logged into the correct accounts, that's for sure.

    I hope I've explaind things succinctly, any ideas how we can get iMessage working again?
     
  2. rugmankc Contributor

    rugmankc

    Joined:
    Sep 24, 2014
    Location:
    Dayton, Ohio
    #2
    I am very much an Apple noob. But, I had same problem when my wife had her Original iPad. Once she got the Air and all on same iOS no issues. When did it start not working. Is it only when messaging bwtn devices on diff iOSs? If issue on same iOS, not sure--sorry.

    ----------

    Support thread with some ideas

    https://discussions.apple.com/thread/3381959?start=0&tstart=0


    Googled that link--:)
     
  3. zorinlynx macrumors 601

    zorinlynx

    Joined:
    May 31, 2007
    Location:
    Florida, USA
    #3
    Have her turn iMessage off, then back on. Wait for "waiting for activation" to complete. I had a similar issue and doing this resolved it.

    Removing and replacing the SIM card may also reset things more thoroughly than doing this.
     
  4. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #4
    Or, sign out of iMessage, reboot, then sign back in if all else fails
     
  5. AFEPPL macrumors 68030

    AFEPPL

    Joined:
    Sep 30, 2014
    Location:
    England
    #5
    Mine tripped out after the latest update - i just turned it off and back on, it was fine after that..
     
  6. JonnyBlaze thread starter macrumors regular

    Joined:
    May 5, 2008
    Location:
    UK
    #6
    Thanks for the suggestions. This problem occurs the same between both of my wife's devices, ios 7 and 8 and mine on iOS 8, so iOS version makes no difference.
    I have tried all of your ideas but nothing has worked. Very annoying!
     
  7. JonnyBlaze thread starter macrumors regular

    Joined:
    May 5, 2008
    Location:
    UK
    #7
    So to close things up, I've figured it out, and it was something to do with the Disconnect app I have been using. When I restarted their service by turning off the VPN and then turning it on again, iMessage now works fine to all contacts. I had been more and more frustrated by this problem as it was affecting all contacts in the end. Now though, having restarted the Disconnect VPN app it's all fine.
     

Share This Page