iMessage not working with one person

Discussion in 'iPhone' started by sim0n, Jan 14, 2014.

  1. sim0n macrumors member

    Joined:
    Apr 28, 2013
    #1
    iMessage has decided to stop working between myself and my friend, this is the person I send the most iMessages to and we have both tried turning our iPhones off and back on, no luck. Does anyone know why this has happend? It's annoying :/
     
  2. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
  3. piranhadonna macrumors regular

    Joined:
    Jun 21, 2013
    Location:
    Chandler, Az
    #3
    I would check your messages settings on both of your devices and make sure that your phone numbers are checked under send and receive at. If it looks good try turning off iMessage and then turning on again.
     
  4. TheAppleFairy macrumors 68020

    TheAppleFairy

    Joined:
    Mar 28, 2013
    Location:
    The Clinton Archipelago unfortunately
    #4
    Have you friend go to setting>messages and make sure iMessage is turned on. Mine turned off randomly a few weeks ago after a crash/reboot.
     
  5. sim0n thread starter macrumors member

    Joined:
    Apr 28, 2013
    #5
    Just tried both of those things and still no change
     
  6. TheAppleFairy macrumors 68020

    TheAppleFairy

    Joined:
    Mar 28, 2013
    Location:
    The Clinton Archipelago unfortunately
    #6
    Did anyone change phone numbers? under imessage settings there is a "send & receive" section, and it list the phone numbers and email addresses to use for iMessage. Maybe it's unchecked or missing?
     
  7. T5BRICK macrumors 604

    T5BRICK

    Joined:
    Aug 3, 2006
    Location:
    Oregon
    #7
    I had something similar happen yesterday, here is what I did:

    Go to Settings > Messages > Send & Receive and tap the Apple ID at the top and sign out.

    iMessage should be turned off now, so go back to Settings > Messages and enable it and sign back in.

    You can try this on your phone, but your friend may need to do it on their phone.
     
  8. The Doctor11 macrumors 603

    The Doctor11

    Joined:
    Dec 15, 2013
    Location:
    New York
    #8
    Hold home and sleep button until you see the apple logo. Do it with both phones it works so so much better then turning it off. Tell me how it goes.
     
  9. cynics macrumors G3

    Joined:
    Jan 8, 2012
    #9

    This, I've had this happen several times and resetting the phone(s) has always fixed it. No data is lost by this type of reset.
     
  10. carjakester macrumors 68020

    carjakester

    Joined:
    Oct 21, 2013
    Location:
    Midwest
    #10
    i had this and reset my network settings and it worked again. settings>general>reset>reset network settings
     

Share This Page