iMessage not working with one person

sim0n

macrumors member
Original poster
Apr 28, 2013
71
0
iMessage has decided to stop working between myself and my friend, this is the person I send the most iMessages to and we have both tried turning our iPhones off and back on, no luck. Does anyone know why this has happend? It's annoying :/
 

piranhadonna

macrumors regular
Jun 21, 2013
239
63
Chandler, Az
I would check your messages settings on both of your devices and make sure that your phone numbers are checked under send and receive at. If it looks good try turning off iMessage and then turning on again.
 
Comment

sim0n

macrumors member
Original poster
Apr 28, 2013
71
0
Just tried both of those things and still no change
 
Comment

T5BRICK

macrumors G3
Aug 3, 2006
8,101
2,093
Oregon
iMessage has decided to stop working between myself and my friend, this is the person I send the most iMessages to and we have both tried turning our iPhones off and back on, no luck. Does anyone know why this has happend? It's annoying :/
I had something similar happen yesterday, here is what I did:

Go to Settings > Messages > Send & Receive and tap the Apple ID at the top and sign out.

iMessage should be turned off now, so go back to Settings > Messages and enable it and sign back in.

You can try this on your phone, but your friend may need to do it on their phone.
 
Comment

The Doctor11

macrumors 603
Dec 15, 2013
5,922
1,334
New York
iMessage has decided to stop working between myself and my friend, this is the person I send the most iMessages to and we have both tried turning our iPhones off and back on, no luck. Does anyone know why this has happend? It's annoying :/
Hold home and sleep button until you see the apple logo. Do it with both phones it works so so much better then turning it off. Tell me how it goes.
 
Comment

cynics

macrumors G4
Jan 8, 2012
11,522
1,845
Hold home and sleep button until you see the apple logo. Do it with both phones it works so so much better then turning it off. Tell me how it goes.

This, I've had this happen several times and resetting the phone(s) has always fixed it. No data is lost by this type of reset.
 
Comment

carjakester

macrumors 68020
Oct 21, 2013
2,228
55
Midwest
i had this and reset my network settings and it worked again. settings>general>reset>reset network settings
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.