iMessage on iPhone and iPad at the same time? This Doesn't Work Correctly.

Discussion in 'iOS 5 and earlier' started by falconman515, Oct 14, 2011.

  1. falconman515 macrumors 6502a

    falconman515

    Joined:
    Jun 8, 2010
    #1
    I currently have iOS 5 on my iPad and iPhone 4 and I can iMessage people that are running iOS 5 apple products.

    Well they don't work in tandem.... I got an iMessage from my wife on my iPhone a few messages later I switched over to the iPad and continued the messages there....... BUT ..... those messages now don't show up on my iPhone and visa versa.

    So if I am at home on my iPad iMessaging and then leave with my iPhone.... all the continued messages now go to my iPad and not my iPhone.

    I thought this crap was suppose to work in tandem???

    I obviously can't have a text conversation on my iPad cause I will then lose everything that comes in after that if I know don't carry my iPad everywhere.

    The only way to get my iPhone getting messages again is to send something from it and not all the incoming messages to the iPhone!

    STUPID.

    Am I missing something here? Cause this is a total iMessage FUBAR if this is the case.
     
  2. boltjames macrumors 68030

    boltjames

    Joined:
    May 2, 2010
    #2
    Same thing here.

    The iPhone goes off of the phone number as it's identifier, the iPad off of the email address.

    It's not good so I've stopped using it. I've got push email for the iPad and I've got my iPhone on me at all times anyway. It's real purpose is to compete with all those apps offering free text messaging which is of no matter to me since I have a huge texting plan and never go over anyway.

    BJ
     
  3. RobS-UK macrumors member

    Joined:
    Jul 11, 2008
    Location:
    Bristol, UK
    #3
    Same problem here. The iPad does not seem to be picking up that on my phone I have associated my phone number with my Apple ID. I've tried turning on and off, logging in and out of all devices etc.

    It says waiting for activation for ages but still doesn't work as I'd hope.

    Shame, as I was really looking forward to this feature.
     
  4. falconman515 thread starter macrumors 6502a

    falconman515

    Joined:
    Jun 8, 2010
    #4
    GOT IT FIGURED OUT .... how to use iMessage across all devices in tandem at the same time.........
    http://howto.cnet.com/8301-11310_39-20107458-285/how-to-get-started-with-imessage/

    "Setting your Caller ID to the same address across all your iOS devices comes in handy if you are wanting to keep all of your iMessage conversations in sync (in real time) across multiple devices. Even if you receive an incoming message at one of your other iMessage-enabled addresses, the outgoing message will be sent using the address of your Caller ID."


    Got this info from an earlier thread here that I found after searching.....
    http://forums.macrumors.com/showthread.php?t=1248467

    WORKS PERFECT NOW !!!
     
  5. kshiz macrumors newbie

    Joined:
    Oct 13, 2011
    #5
    Do that and reset your network settings in General -> Reset -> Reset network settings

    Worked like a charm.
     
  6. falconman515 thread starter macrumors 6502a

    falconman515

    Joined:
    Jun 8, 2010
    #6
    Mine worked fine when changing the Caller ID portion.

    What is the purpose of resetting the network settings?
     

Share This Page