iMessage on iPhone has no "Receive at" number option

Discussion in 'iOS 5 and earlier' started by M. Malone, Oct 14, 2011.

  1. M. Malone macrumors 6502a

    M. Malone

    Joined:
    Mar 11, 2004
    #1
    Hello,

    Just wanted to ask what the problem may be.

    iMessage in my iPhone 4 only gives me the option to add extra email addresses to the "Receive At" section. I want to add my number but it won't.

    Also, in settings under phone, my number appears there so I have no idea what iMessage will only let me use an email.

    Thanks.
     
  2. XjeffX macrumors member

    Joined:
    Jun 4, 2004
    #2
    I'm having the same issue.. ? =/

    ----------

    Found a solution that worked for me.

    First see in https://appleid.apple.com if your apple ID is linked with your iPhone phone number, if not, modify and save changes, then in your iPhone go to settings -> messages -> and deactivate iMessage and activate it again (the phone number should appear in "Receive At" greyed out). Do the same in settings -> FaceTime. After that reboot your iPhone. Hope that works, it worked for me
     
  3. MyRomeo macrumors 6502

    MyRomeo

    Joined:
    Jul 22, 2010
    Location:
    United Kingdom
    #3
    My couz had this problem too, I turned iMessage off, rebooted phone and turned iMessage back on and it seemed to work.

    Regarding the appleid saved number, just checked mine and it was still my old number yet iMessage works fine on new number so I suspect that is not needed.
     
  4. anuj2607 macrumors newbie

    Joined:
    Feb 11, 2012
    #4
    updating https://appleid.apple.com didn't work

    Hi I tried updating info on https://appleid.apple.com . have turned off iMessage and Facetime, then restarted. After restart, iMessage & F'time show awaiting activation.
    would appreciate a step-by step solution.
    i have 1 jailbreaked and 1 factory unlocked iPhone 4. On the factory unlocked, it is showing receive at option, but not on the jailbreaked phone.

    Till now, my friends tell that they receive iMessage from my email address.

    thanks in advance
     
  5. thewitt macrumors 68020

    thewitt

    Joined:
    Sep 13, 2011
    #5
    You guys might want to post in a hacking forum if you are having troubles on jail broken phones.
     
  6. bigalow, Jul 29, 2012
    Last edited: Jul 29, 2012

    bigalow macrumors member

    Joined:
    Feb 16, 2012
    #6
    my phone isn't jailbroken and I have this exact issue - so if there are any other ideas I would love to hear them.

    thanks

    edit:

    actually, I just got the 'receive at' option - I just can't change it from my email address to my phone number
     
  7. dontpannic macrumors 6502

    dontpannic

    Joined:
    May 16, 2011
    Location:
    Orpington, Kent, UK
    #7
    The solution to all of this is just to turn iMessage off and on again.
     

Share This Page