iMessage on Mac, but SMS on iPhone...

Discussion in 'iOS 6' started by Nucleophile, Mar 24, 2013.

  1. Nucleophile macrumors newbie

    Joined:
    Oct 2, 2009
    Location:
    Plano, TX
    #1
    So I have a question here about what is happening to my messages.

    I was texting someone via iMessage all morning on my iPhone with no problems. Sometime in the afternoon, my phone started slowing on sending and eventually, it turned to sending messages as SMS. That's fine as I know iMessage ability can be hindered by the receiving party's connection too.

    However, when I look at iMessage opened on my iMac, it shows those same messages and says their status is "Delivered."

    So which did it send as - SMS or iMessage? And most importantly, did they send at all...? No reply from the recipient yet, so I'm just hoping the messages made it through...
     
  2. FSMBP macrumors 68020

    FSMBP

    Joined:
    Jan 22, 2009
    #2
    It probably sent both; I've seen this a lot. iMessage will fail and the iPhone will send it as SMS. However, it may try to resend the iMessage.

    For example, my friend sent me a SMS via his iPhone this morning. Then 2 minutes later, I got the same exact message as an iMessage.
     
  3. ProudLoz macrumors regular

    Joined:
    Aug 26, 2012
    #3
    Yeah, I had the exact issue once. I think what happens is that when an iMessage fails on your iPhone, it sends it as a SMS, but since it's also sending it via your Mac, the Mac tries to resend it later, and so you also send an iMessage, but it just doesn't show up on your phone since it's the exact same message.
     
  4. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #4
    Unless you modded the bubble colors, if it is blue on the phone, it was sent as iMessage.
    Green as an SMS.
     
  5. K3gy macrumors newbie

    Joined:
    Apr 30, 2013
    #5
    I have a different issue. How can I have my iMessages come to my phone only, and not to my iPad? I only want my sms on my phone. Any help?

    ----------

    Should I just turn off iCloud on my iPad?
     
  6. inselstudent macrumors 6502a

    Joined:
    Jul 27, 2012
    #6
    I think you can disable only iMessage in Settings>Messages
     
  7. MrMacMack macrumors 6502a

    Joined:
    Oct 24, 2012
    #7
    Yes, from Settings > Messages and then turn iMessage off.
     
  8. Nucleophile thread starter macrumors newbie

    Joined:
    Oct 2, 2009
    Location:
    Plano, TX
    #8
    FSMBP and ProudLoz, that happened to be the issue at hand. Many thanks!
     

Share This Page