iMessage on Mac not showing contact names

Hicksmat1976

macrumors regular
Original poster
Jul 12, 2016
155
124
Middleton, England
Hello

I have 2 Macs all running the latest MacOS and an iPhone running the latest iOS. All three devices are using the same master iCloud contacts list and there are no other contacts accounts activated.

One one Mac I have an issue whereby some of iMessages are showing as phone numbers rather than resolving to the contact name.

logging out and in again to iCloud and rebooting has not resolved the issue. Anyone else seen this?
 
  • Like
Reactions: loyal

deltaflyer37

macrumors newbie
Sep 23, 2015
1
1
Hello

I have 2 Macs all running the latest MacOS and an iPhone running the latest iOS. All three devices are using the same master iCloud contacts list and there are no other contacts accounts activated.

One one Mac I have an issue whereby some of iMessages are showing as phone numbers rather than resolving to the contact name.

logging out and in again to iCloud and rebooting has not resolved the issue. Anyone else seen this?
I have the same issue with my Macbook Pro running latest Sierra. Any fixes?
 
  • Like
Reactions: loyal

Hicksmat1976

macrumors regular
Original poster
Jul 12, 2016
155
124
Middleton, England
I thought the format of the phone number might have a relevance. I'm in the UK so we use +44

If I alter one of my contacts to have +44 as a prefix and then try iMessaging that contact it works. weird.

this is just started happening today.
 
  • Like
Reactions: Relievo

nopantsuk

macrumors newbie
Apr 16, 2010
12
1
I'm in the UK and starting having this issue too, tried all the suggestions in various threads but no luck, kinda annoying!
 

BrianBaughn

macrumors 603
Feb 13, 2011
6,375
942
Baltimore, Maryland
We just had a similar, if not the same, issue on one iPhone. Some were showing as phone numbers and some were displaying "Maybe:" and a contact's name which wasn't always right.

Switching the toggle at Settings>Contacts>Contacts Found in Apps to "Off", turning of sync the Contacts account and then re-enabling the same Contacts account seemed to fix it.
 

Hicksmat1976

macrumors regular
Original poster
Jul 12, 2016
155
124
Middleton, England
this isn't on a phone, its on a Mac running latest Sierra.

I think I have narrowed it down to region/locale settings.

until a few versions of OSX ago the iMessage app allowed you to toggle the country of origin/location within the app preferences, and in fact FaceTime still has this setting in its app preferences. iMessage now relies on the region/locale setting on MacOS to determine its current location, and if this is set incorrectly I think it wouldn't know how to translate a mobile number properly e.g. put a +44 in front go it automatically if you were based in the UK. In essence your Mac wouldn't know where in the world you were. I've gone into Terminal and typed "locale" and it is set to GB, but there must be something not quite right so I think I'll keep investigating.
 

Hicksmat1976

macrumors regular
Original poster
Jul 12, 2016
155
124
Middleton, England
update:

been on to apple today. they even did a remote control session. I've beaten them - this is a problem they cannot solve.

super annoying but I guess its a bug somewhere.
 

hounderawr

macrumors newbie
May 29, 2017
1
0
update:

been on to apple today. they even did a remote control session. I've beaten them - this is a problem they cannot solve.

super annoying but I guess its a bug somewhere.
did you happen to find a fix for this? I just recently bought a MacBook Pro and am having the same issue, called apple phone support and the guy told me that "thats how it works on a Mac" on my Mac it adds in the country code +61 (Australia) but my phone works fine and the messages do sync.

I went to Mac->imessage preferences->accounts and ticked/unticked multiply times the "enable this account" option and fixed the issue.
tried that, but it didn't fix anything though.
 

eRondeau

macrumors 65816
Mar 3, 2004
1,023
99
Canada's South Coast
I've had that happen too. Messages is pretty shaky most of the time but persistence will pay off. Sign ALL your devices out of iCloud (including iOS & MacOS) and once they're all signed-out reboot them all. Then sign them all back in to iCloud & Messages one at a time. All your devices will need time to activate Messages. Hopefully that'll fix it. If it doesn't work the first time, try it again. Messages syncing via iCloud is black magic at best.

I'm no expert at this next bit of advice so accept with strong caution. But I once had a corrupt entry in my Contacts that caused all sorts of weird behaviour whenever names were needed. I discovered it by searching in the Console for "Contacts" and it was pretty obvious with 100+ errors with that one contact in particular (I'd say up to a couple dozen is normal at any given time, but 50+ might signify a problem.) In my case simply deleting the offending single Contact on the server using iCloud.com and then re-adding it fixed everything right up and console messages slowed right down.
 

brettdouglas

macrumors newbie
Jun 7, 2017
1
2
Hello

I have 2 Macs all running the latest MacOS and an iPhone running the latest iOS. All three devices are using the same master iCloud contacts list and there are no other contacts accounts activated.

One one Mac I have an issue whereby some of iMessages are showing as phone numbers rather than resolving to the contact name.

logging out and in again to iCloud and rebooting has not resolved the issue. Anyone else seen this?

I've only just come across this issue recently and have been on the phone to Apple to figure it out for hours, which seemed to go no where. I have figured out why this happens. Im from the UK and the UK code is +44. When I looked up the contacts that wouldn't display the name, all of them began with 07, instead of +44. As soon as I changed all of the numbers to +44, the issue has been resolved. This also solved issues that said certain contacts were not registered to iMessage, etc. Hope this helps.
 

BahmanS

macrumors newbie
Jun 7, 2017
1
5
I had the same issue, and eventually I figured what was the problem with me, and I wonder if this might solve the issue for some (if not most):

It turned out that I had two contact lists (Google and iCloud) on my iPhone but only one (iCloud) on my Mac. Most of my contact names were on Google, and once I added this to Mac, all the names came through on iMessages as well!
 

Hicksmat1976

macrumors regular
Original poster
Jul 12, 2016
155
124
Middleton, England
I've only just come across this issue recently and have been on the phone to Apple to figure it out for hours, which seemed to go no where. I have figured out why this happens. Im from the UK and the UK code is +44. When I looked up the contacts that wouldn't display the name, all of them began with 07, instead of +44. As soon as I changed all of the numbers to +44, the issue has been resolved. This also solved issues that said certain contacts were not registered to iMessage, etc. Hope this helps.
the point is you shouldn't have to change all your contacts. There is a region setting in MacOS which if working correctly recognises your "locale" e.g. UK and therefore formats your numbers appropriately when you send a message. All you have done is reformat all your numbers, which I do not want to do, so while this is a workaround it isn't a solution mate.
 
  • Like
Reactions: Phil in ocala

garretht

macrumors newbie
Jun 12, 2017
1
1
I see these posts are over a year old? Has anyone figured out a workable solution? I got a new MacBook about a week ago, upgraded to Sierra, etc. and have set all my regions to South Africa on the MacBook and iCloud, but the messages are still only showing numbers.
 
  • Like
Reactions: jjini

alisonthursby

macrumors newbie
Jun 11, 2017
10
1
I too have this issue. I also have an issue of old contacts appearing in my recipient box which I can't get rid of. I've no idea how they've appeared as I haven't messaged those people on my MacBook. Anyone have any ideas?
 

Hicksmat1976

macrumors regular
Original poster
Jul 12, 2016
155
124
Middleton, England
I too have this issue. I also have an issue of old contacts appearing in my recipient box which I can't get rid of. I've no idea how they've appeared as I haven't messaged those people on my MacBook. Anyone have any ideas?
how many accounts do you have in your "contacts" on your Mac/phone? they may be coming from iCloud/google/or even on your SIM card.
[doublepost=1497271642][/doublepost]
I see these posts are over a year old? Has anyone figured out a workable solution? I got a new MacBook about a week ago, upgraded to Sierra, etc. and have set all my regions to South Africa on the MacBook and iCloud, but the messages are still only showing numbers.
https://forums.macrumors.com/thread...-showing-contact-names.2045918/#post-24597270
 

alisonthursby

macrumors newbie
Jun 11, 2017
10
1

alisonthursby

macrumors newbie
Jun 11, 2017
10
1
Hi again. Ok so in the contacts app on the Mac and under preferences and accounts what services do you see? Are your correct contacts on icloud?
Hi again. Ok so in the contacts app on the Mac and under preferences and accounts what services do you see? Are your correct contacts on icloud?
This is what I can see. The contacts on my iCloud are correct - whenever I go to type a message in Messages it comes up with a bunch of people who aren't on my contacts anywhere so I am extremely confused and frustrated.
 

Attachments

Hicksmat1976

macrumors regular
Original poster
Jul 12, 2016
155
124
Middleton, England
This is what I can see. The contacts on my iCloud are correct - whenever I go to type a message in Messages it comes up with a bunch of people who aren't on my contacts anywhere so I am extremely confused and frustrated.
Ok that looks correct. So these rogue contacts are just on the Mac and not the phone?

You could try logging out of icloud on the Mac and then do a restart of the Mac and then re-sign into icloud to see if everything resyncs including contacts.

Or try some of the suggestions here if that doesn't work
https://discussions.apple.com/thread/7683562?start=0&tstart=0
 
  • Like
Reactions: DeepIn2U