iMessage on Macbook Pro

Discussion in 'Mac Basics and Help' started by Geffen, Nov 28, 2015.

  1. Geffen macrumors 6502

    Joined:
    Sep 23, 2007
    Location:
    Michigan
    #1
    I recently upgraded my mid 2009 Macbook Pro to El Capitan and my iMessages from my iPhone is loading each time i boot up my Macbook Pro. Is there a way to turn this feature off so my iMessages do not show on each boot up?
     
  2. aristobrat macrumors G5

    Joined:
    Oct 14, 2005
    #2
    Do you want to never get iMessages on your Mac? If so, go into Preferences in iMessages on the Mac and sign out of the iMessage account.
     
  3. Geffen thread starter macrumors 6502

    Joined:
    Sep 23, 2007
    Location:
    Michigan
    #3
    I don't mind having iMessages on my Mac, I just don't want them appearing each time I boot. I was on Mavericks before El Capitan and never had this issue. I just want to open the iMessages up myself whenever I want to respond on my Mac instead of my iPhone.
     
  4. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #4
    Are you stating that the physical Messages application is opening on boot or that you are seeing notifications for pending messages on your iPhone every time you boot?
     
  5. aristobrat macrumors G5

    Joined:
    Oct 14, 2005
    #5
    I have the latter happen on mine. Even if iMessage isn't open, pending iMessages will appear in the Notifications area as they arrive on my Mac.
     
  6. Geffen thread starter macrumors 6502

    Joined:
    Sep 23, 2007
    Location:
    Michigan
    #6
    It's the physical messages application thats opening on each boot. Where I can start new messages or continue texting where I left off on my iPhone. The application never opened on each boot before until i upgraded to El Capitan. I don't mind closing or minimizing the application each time however there should be a way where they wouldn't show unless you click on the iMessages.
     
  7. Geffen thread starter macrumors 6502

    Joined:
    Sep 23, 2007
    Location:
    Michigan
    #7
    I figured it out. There's an option under messages to hide messages. Now when i boot my iMessages do not open automatically.
     
  8. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #8
    @Geffen A future tip for applications opening on log in is to right click the icon in the Dock and uncheck "Open at Login".
     

Share This Page