Resolved iMessage on more then one device.

Discussion in 'iOS 5 and earlier' started by helios16v, Feb 20, 2012.

  1. helios16v, Feb 20, 2012
    Last edited: Feb 20, 2012

    helios16v macrumors regular

    Joined:
    Nov 1, 2008
    Location:
    Earth
    #1
    I recently upgraded one of my beloveds to the 10.8 DP1 and started using iMessage, however I noticed straight away that it disabled it on my iPhone, and it did the same thing a while ago when I was using iMessage on my iPad..

    Why can't I use iMessage on all three at once so every message sent and received is on all three devices?

    It is extremely annoying to be getting random iMessages and SMS from the same person on two different devices because their iPhone doesn't know which one to keep sending me.

    I just wanna have iMessage turned on for my iPhone, iPad, and MacBook Pro while they are all capable of sending messages to my iMessage contacts as well as receiving the same message on all three devices so I don't have to check all three to see which one the message sent too.
     
  2. whoathere macrumors 6502

    whoathere

    Joined:
    Feb 8, 2006
    Location:
    Rockford, IL
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    I wondered about this since I will be getting the new iPad and have an iPhone 4
     
  3. helios16v thread starter macrumors regular

    Joined:
    Nov 1, 2008
    Location:
    Earth
    #3
    Does this mean that all three of my devices are all not working properly?!

    https://discussions.apple.com/thread/3606515?start=0&tstart=0

    Because after reading through this it seems that what I want iMessage to do is EXACTLY what it is suppose to be doing.. and non of my devices are working the way they should be!
     
  4. helios16v thread starter macrumors regular

    Joined:
    Nov 1, 2008
    Location:
    Earth
    #4
    I figured it out, the iPhone was using my mobile number, my iPad was using my Apple ID and my MBP was using my @me lol

    I added my @me email to all of them, removed my registered Apple ID email and they all work perfect now..
     

Share This Page