iPhone iMessage photos not being sent

Discussion in 'Jailbreaks and iOS Hacks' started by mrmister, Mar 5, 2013.

  1. mrmister macrumors regular

    Joined:
    Dec 19, 2008
    #1
    Some kind of a bug--iMessages go out, unless they are images. Then they look delivered, then become marked undelivered, and never go out. Going to start playing with turning off my mobile substrate extensions...but does anyone have a clue about this?
     
  2. mrmister thread starter macrumors regular

    Joined:
    Dec 19, 2008
    #2
    Ok, used iCleaner to disable everything...and the bug is still there. Very repeatable. When using iMessage, sending an image causes it to appear to go out...but it doesn't, and moments later it snaps back as unsent.

    Really not sure what to try next.
     
  3. mrmister thread starter macrumors regular

    Joined:
    Dec 19, 2008
    #3
    Beginning to suspect that iMessage is screwed up...may have nothing to do withJB. Incredibly annoying!
     
  4. sagar4995 macrumors 6502a

    sagar4995

    Joined:
    Aug 11, 2012
    Location:
    Dubai, UAE
    #4
    no i dont think the JB has to do with this. I've noticed this too... images sent thru imessage take VERY LONG... most of the times, they go thru. the reason, i think, is cos the image files sent thru imessage are high-res (1-2 mb). a workaround i use is sending images thru whatsapp. images sent thru whatsapp are relatively lower res as compared to imessage images. now if ur network isin't that good or fast, imessage will have difficulty transferring the images.

    try this: send the same image over imessage as well as whatsapp to the same contact & have ur friend save both images n look at their size. it'll surprise u. i did this.
     
  5. schizbomb macrumors 6502

    Joined:
    May 14, 2011
    Location:
    Texas
  6. Skizzy macrumors regular

    Skizzy

    Joined:
    Feb 4, 2013
  7. mrmister thread starter macrumors regular

    Joined:
    Dec 19, 2008
    #7
    I don't have Copic or Erica's Utilities installed...still can't lock down what is happening. Will try experimenting with file sizes tomorrow.
     
  8. jimmythehill macrumors member

    Joined:
    May 31, 2010
    #8
    Are we going to be inundated now with threads about iMessage not working properly?
    I started one yesterday which funnily enough is on page one of this message board!
    It wpuld be great if people could keep all the threads together rather than us all having to open numerous , yet all related to the same subject, posts.
     
  9. BumpyFlatline, Mar 6, 2013
    Last edited: Mar 6, 2013

    BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #9
    Ironic you say this because when you started your thread there were already one or two current threads on this topic....

    Edit: I should prolly point out that I'm just bustin your balls. It's hard to show tonality in text. I personally don't care because I've given up hope that we can things organized in one thread. I usually just tell the OP's that there is another thread with helpful info and to go find it. If I know exactly where the thread is I'll paste a copy of the link for the OP. Kind of wish that the mods were more proactive in merging duplicate threads. There are at least 3 of these iMessage threads, there are 3 "weird keyboard space layout" threads, roughly 4 "winterboard is closing backgrounded apps" threads and so on and so forth. It would be wicked awesome if a moderator would merge these when the evolve into large, multiple page threads so we can keep all the info centralized. Oh well. Not the end of the world lol
     
  10. evotoiphone macrumors regular

    Joined:
    Oct 7, 2011
    Location:
    Mass
    #10
    OK I am glad this is happening to someone else too! A friend of mine tried very unsuccessfully to send me a picture yesterday. She is on an iPhone 4s NOT jailbroken. Then she tried to send it to others and it went through just fine. Now I have since had others send my pictures via non-jailbroken iPhones, and Androids. She is also receiving pics that I send to her. We thought it may be a carrier issue as she is on AT&T and I on Sprint but she was able to send pics to another Sprint user. I have received many pics from her in the past.

    So your guess is as good as mine.
     
  11. Shredder96 macrumors regular

    Joined:
    May 15, 2012
    #11
    Yeah does anyone know a possible fix for this?
     
  12. BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #12
    This is strange. I'm not experiencing this on my phone. I'm using an AT&T 4S on 6.1.2. I send pics and videos from my camera roll all the time. I can send and receive them. Very strange that you guys can't do this. Is there a common Cydia package you all have installed that is causing this? Might be time for everyone to start listing their installed package list to see if we can determine a lowest common denominator.
     
  13. mrmister thread starter macrumors regular

    Joined:
    Dec 19, 2008
    #13
    There's actually a huge thread in the iPhone forum about people having this issue on Verizon iPhones.

    http://forums.macrumors.com/showthread.php?t=1458503

    Consensus there seems to be that it is not jailbreak, it is not software, and not hardware—that instead there may be a problem on the carrier side connecting with iMessage. That would make some sense, as there is very little continuity otherwise—people get it at random whether you are JB or not, on whatever service, etc. My wife is on a Verizon iPhone 5, jailbroken, and has no problems at all. And I tried everything (as have people in that thread, including replacement!) and still have this odd issue.

    It's a real puzzler.
     

Share This Page