iMessage problem on 5S after 7.1.2 update

Discussion in 'iOS 7' started by manishans, Jul 1, 2014.

  1. manishans macrumors member

    Joined:
    Oct 5, 2013
    #1
    Hi All,

    I just updated my 5S to iOS 7.1.2 and did a full reset which I do after each update. Since this reset I'm unable to activate iMessages or Facetime.

    It shows 'Waiting for activation' and also I received several messages from a US or UK number saying "REG-RESP?a bunch of numbers and letters".

    Any idea what to do? :(
     
  2. manishans thread starter macrumors member

    Joined:
    Oct 5, 2013
  3. I7guy macrumors P6

    I7guy

    Joined:
    Nov 30, 2013
    Location:
    Gotta be in it to win it
    #3
    you could try signing out of iMessage and then signing back in.
     
  4. Rogzilla macrumors regular

    Joined:
    Sep 11, 2007
    #4
    You know, I've been having an iMessage problem as well. I can get on but I can't send photos. For some reason, they always go from "delivered" to "delivery failed."
     
  5. George Knighton macrumors 65816

    George Knighton

    Joined:
    Oct 13, 2010
    #5
    I have also been having issues that I cannot explain, but I was chalking it up to the Pangu jailbreak.
     
  6. Stuke00 macrumors 68000

    Joined:
    Oct 11, 2011
    Location:
    Collinsville,IL
    #6
    I had this issue too. Hit reset all settings and it activated.
     
  7. manishans thread starter macrumors member

    Joined:
    Oct 5, 2013
    #7
    Thanks all! I spoke to Apple and they instructed me to switch cellular data and activate iMessage while connected to WiFi. Did it and it activated a few mins later!

    Thanks
     

Share This Page