iMessage problem

Discussion in 'iPhone' started by dogKman822, Jan 7, 2014.

  1. dogKman822 macrumors member

    Joined:
    Oct 27, 2012
    Location:
    USA
    #1
    So today, I restored my phone to factory settings because i was having trouble with some stuff. The restore was successful except now my number isn't working with iMessage. It's greyed out and I can only use my email to send messages. It's really bothersome because iMessage is so much faster than texting.
    Any fix?
     
  2. nwmtnbiker macrumors 68000

    nwmtnbiker

    Joined:
    Apr 5, 2011
    Location:
    Fidalgo Island
    #2
    You could try and check your settings. Settings/Messages/Send & Receive. Make sure you have your phone # selected. If that isn't it possible could be a setting in iTunes that is the same?
     
  3. I7guy macrumors G5

    Joined:
    Nov 30, 2013
    Location:
    What Exit?/Saguaro Country
  4. PNutts macrumors 601

    PNutts

    Joined:
    Jul 24, 2008
    Location:
    Pacific Northwest, US
    #4
    The phone number should be grey because it can't be removed, but you should still be able to tap it and put the checkmark next to it if you added an e-mail address to the list. I don't know if it will have a checkmark if it's the only item in the list.
     

Share This Page