iMessage Question -- International Users

Discussion in 'iOS 5 and earlier' started by drkwtsn, Oct 16, 2011.

  1. drkwtsn macrumors member

    Joined:
    Aug 12, 2010
    #1
    So iMessage is great, I live in Italy and it makes texting my friends cheap and easy.... But I am having a problem.


    I can't seem to get my phone to send a sms through iMessage to one of my friends in the states unless I put in his email. If I leave it as +1 (XXX) XXX-XXXX it doesnt recognize it as an imessage number. Under his registered numbers he says it lists 1 (xxx) xxx-xxxx as the number. I can send it to his registered gmail account no problem, and he can send to my +39 number just fine


    Any ideas? Is this a glitch when sending to stateside numbers?
     
  2. mreddys10 macrumors regular

    Joined:
    Jul 29, 2008
    #2
    I've been messaging someone in the US with no problems. I think your friend need to check if his phone number is present under Settings>Messages>Receive At. If his phone number is already present, then it's definitely a glitch. Ask him to restart once and try
     
  3. drkwtsn thread starter macrumors member

    Joined:
    Aug 12, 2010
    #3
    his phone number is present, but it doesnt have the +1 , just 1 (xxx)xxx-xxxx

    I have his number as +1 (xxx)xxx-xxxx, does this make a difference?
     
  4. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #4
    I checked mine at settings, messages, Receive at and the number is
    +1 (xxx) xxx-xxxx. That is also how it is entered under my contacts. I always use +country code on every one of my contacts because I travel a lot.
     
  5. r2shyyou macrumors 68000

    r2shyyou

    Joined:
    Oct 3, 2010
    Location:
    Paris, France
    #5
    If I understand it correctly, iMessage uses data to deliver messages, as opposed to cellular, and so it would not make sense for it to work internationally using a phone number instead of an email address since that would go via cellular and be an text message, not an iMessage.

    My older brother and I iMessaged just the other day (between Belgium and US) and we both have each others phone number correctly in our respective contacts, as proven by previous phone calls and text messages, and our iMessages were delivered to each others email addresses and not phone numbers.
     
  6. ru4real macrumors member

    Joined:
    May 19, 2010
    #6
    Even though the messages are going through data, Apple can still use the phone number as the identifier. My guess in this case is that the problem lies in the fact that your US friend doesn't have the "+" in his number, but you are trying to find him on iMessage with it there. Try removing the + (or have your friend add it on his end)
     
  7. drkwtsn thread starter macrumors member

    Joined:
    Aug 12, 2010
    #7
    makes sense, but he can send it to me via cell phone number to my italian cell

    maybe i need to make sure he puts the +1 instead just 1 in his phone


    i did try removing the + and it didnt work either
     
  8. mreddys10, Oct 16, 2011
    Last edited: Oct 16, 2011

    mreddys10 macrumors regular

    Joined:
    Jul 29, 2008
    #8
    I don't have an email address for my friend's contact stored on my phone. Just his phone number. I agree with ru4real



    ----------

    I can't edit my phone number. It's greyed out
     

Share This Page