iMessage question

Discussion in 'iOS 5 and earlier' started by CDutch, Oct 13, 2011.

  1. CDutch macrumors regular

    Joined:
    Jul 6, 2009
    #1
    Seems like there are quite few posts about iMessage but I didn't see a response to this question. Apologies if it's already been asked and I missed it.

    I have a bunch of friends and family with iPhones and iPads who are yet to update to iOS 5 but will likely be doing so soon. My question is how will users know to send an iMessage to the Apple ID as opposed to the iPhone number that is normally used for texting? Reason I ask is that it appears that iMessages must be sent to the Apple ID to sync across devices and I was curious if there was a way to ensure that the messages sent from other iOS devices are sent to the Apple ID and not my phone number?
     
  2. sakau2007 macrumors 6502

    Joined:
    Oct 12, 2011
    #2
    i'm not sure how it is working, but it is.

    i have a friend who upgraded to iOS 5 and when he did, when i go to "text" him, it automatically knows to send it as an iMessage.
     
  3. MooneyFlyer macrumors 65816

    MooneyFlyer

    Joined:
    Nov 18, 2007
    Location:
    Boston
    #3
    It doesn't seem to handle this case. You could simply tell everyone you know with iOS devices to start sending to your Apple ID. If someone starts a conversation using iMessage to a phone number (looks like a text), it will not transfer to your iPad (under Apple ID) later.

    Apple quickly looks up the phone number for the person you are texting and determines if they are on iMessage. You can type in someone's name and you will see the "send" button turn blue if they are on iMessage, green if not. The first time it might take a second or two...
     
  4. Hamoodi macrumors member

    Joined:
    Aug 29, 2010
    #4
    Great question. When both the sender and receiver have iOS 5. And are both on WiFi (Not sure about wifi part), it automatically uses iMessage. I used it a lottttt today. It is a great thing too. VERYYYY fast message sending. And you can also see when people are typing. It is like a chatroom. I LOVE IT@!!!!:):):):D:D:D:apple:
     
  5. CDutch thread starter macrumors regular

    Joined:
    Jul 6, 2009
    #5
    Do you have an iPad as well? I'm curious about the syncing between my iPhone and iPad.
     
  6. spblat macrumors 6502a

    spblat

    Joined:
    Jun 18, 2010
    #6
    It simply works. I had an early version and texting with my friend I used SMS. Yesterday he sent me a text and it came over iMessage. What seems to happen is the first message between iMessage-compatable devices will be SMS. after that they figure out they can use iMessage, and they do. It just works.
     
  7. sakau2007 macrumors 6502

    Joined:
    Oct 12, 2011
    #7
    I do not. iPhone 4 is my only iOS 5 device.
     
  8. spblat macrumors 6502a

    spblat

    Joined:
    Jun 18, 2010
    #8
    Syncing doesn't "just work" for all contacts. Only in cases where you and your correspondent associate apple ID's with your iMessage setup. My wife and I have done that, and so I see all our text conversations on my iPad. Even though I have a friend with iMessage, his texts don't show up on my iPad.
     
  9. French macrumors regular

    Joined:
    Jan 13, 2011
    #9
    The problem comes in here:

    You have an iPad and iPhone

    Your friend has an iPad and iPhone.

    You send your friend a message at his apple ID, thus ensuring the message goes to both his iPad and iPhone.

    He replies to you, but you only get his reply on your iPhone. Why? Because your iPhone defaults to using your phone number and you can't change it.

    So there is a serious disconnect that I can't figure out how to fix. There's no way to change your iPhone to have your message come from your apple ID instead of your phone number.
     
  10. CDutch thread starter macrumors regular

    Joined:
    Jul 6, 2009
    #10
    Yep. But for some reason, the iMessages that are directed to my phone number are not syncing to my iPad. However, iMessages sent to my Apple ID are syncing across devices. What I'd like to figure out is how to ensure that the sender directs the iMessage to the Apple ID and not the phone number so my iMessages sync between my iPad and iPhone.
     
  11. ShadowofBob macrumors newbie

    Joined:
    Jul 24, 2011
    Location:
    Palo Alto, CA
    #11
    You have to put their Apple ID in their Contact Card on your phone. This will create two conversations. Now whenever you get an iMessage from them it will be via the email/Apple ID address.
     
  12. MooneyFlyer macrumors 65816

    MooneyFlyer

    Joined:
    Nov 18, 2007
    Location:
    Boston
    #12
    I think you have to tell them -- that is the only way that anyone can figure out.
     
  13. d0ster macrumors regular

    Joined:
    May 3, 2011
    #13
    Go into Settings-Messages and then add your mobile me email into the list for "Recieve at addresses". Should take care of your problem
     
  14. CptnJustc macrumors 6502

    Joined:
    Jan 19, 2007
    #14
    Yeah, getting this exact situation with my wife. #firstworldproblems
     
  15. CrAkD macrumors 68040

    CrAkD

    Joined:
    Feb 15, 2010
    Location:
    Boston, MA
    #15
    if you set your caller id as the email on your phone and delete any old text messages that you had before you did this then message the other person they will get it as a seperate convo but from then on it should work......still not ideal. apple needs to find a way for users to sync ipad and iphone together without bothering the person your messaging with it. RIM can do it apple should be able to as well.
     
  16. jmo1116 macrumors regular

    Joined:
    May 27, 2010
    Location:
    Alabama
    #16
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    When I get a new iMessage from my mom, it comes in as her phone number. Then I try to "add contact" and after doing so it still doesn't show up as from "mom". It still shows her phone number. Also happened with another friend who texted me. Anyone know how to fix this?
     
  17. CptnJustc macrumors 6502

    Joined:
    Jan 19, 2007
    #17
    Ah, you're right. I had already set the caller ID as the same email as on my iPad, but the trick appears to have been just deleting all old threads with the person I was texting. I didn't have to delete any others. Syncing well now, thanks.
     
  18. kshiz macrumors newbie

    Joined:
    Oct 13, 2011
    #18
    Riddle me this: You have an iPad and an iPhone

    You send a NEW iMessage to a friend from your iPhone. (meaning, you don't have a message to this particular friend on your iPad)

    Does this message show up on your iPad? It doesn't for me. If I wanted to continue this convo I would have to essentially start a new message on my iPad.

    I have my caller ID on both set to my email.

    What my friends have told me is that the first time I send from my iPad they get a new thread. But once they start responding to that new thread everything works and my iPad and iPhone sync up. Weird and not really seamless. And I'm pretty sure they're responding to my "email" ID not my phone number.

    I'm assuming this is the way it is until Apple releases an update.
     
  19. johnray10 macrumors member

    Joined:
    Oct 7, 2011
    #19
    just restart your phone. mine was doing that at first to a few of my contacts that were using iMessage. it fixed it after a restart and hasn't happened since. you know, it is suggested to restart your iPhone once a day or every other day. its like a little computer. needs to be shut down and restarted every once in a while. it does wonders for your phone. most people don't realize this...
     
  20. pourme macrumors regular

    pourme

    Joined:
    Aug 19, 2009
    Location:
    North Carolina
    #20
    I appreciate all the answers in this thread. Cleared up a lot of questions for me!...Thanks!...
     
  21. CptnJustc macrumors 6502

    Joined:
    Jan 19, 2007
    #21
    I think so. Sadly, I don't have enough iOS-utilizing friends to be able to test it extensively.

    They should be able to tell for sure what address they're responding to by tapping the person-shaped icon on the top right in iPad iMessage, or 'contact info' at the top of an iPhone thread.
     
  22. CDutch thread starter macrumors regular

    Joined:
    Jul 6, 2009
    #22
    Just experienced the same issue. It's quite annoying.
     
  23. Gandalf! macrumors member

    Joined:
    Jun 15, 2005
    #23
    I've been sending iMessages to my friend who just bought a 4s. Last night, one of my messages said "sent as text message" and was in green.

    The thing is - I removed my texting plan from AT&T. He responded however, and as of right now, my data plan shows I haven't sent any text messages. Weird.
     
  24. r2shyyou macrumors 68000

    r2shyyou

    Joined:
    Oct 3, 2010
    Location:
    Paris, France
    #24
    Within Settings>Messages, do you have "Send As SMS" turned on? If so, your iMessages will revert to text messages if the recipient's data connection is unavailable.

    That being the case and since you removed your texting plan from AT&T, I'd imagine you'll be charged $0.25 for each text message (or $0.20, I don't remember exactly).
     
  25. MooneyFlyer macrumors 65816

    MooneyFlyer

    Joined:
    Nov 18, 2007
    Location:
    Boston
    #25
    On my phone (4S, AT&T) there is a setting under:
    Settings -> Messages -> "Send as SMS" [ON/OFF] to disable that. Seems that it could get expensive.
     

Share This Page