iMessage question

Discussion in 'iOS 6' started by Italianblend, Sep 21, 2012.

  1. Italianblend macrumors 68000

    Italianblend

    Joined:
    Mar 21, 2011
    Location:
    Fatima
    #1
    Sometimes I text a friend with iPhone and iPad. She has my email and phone under one contact. But if I iMessage her on phone and switch to iPad, it shows up as a separate person on the list. Is there a way to keep it as the same conversation? Thanks.
     
  2. Italianblend thread starter macrumors 68000

    Italianblend

    Joined:
    Mar 21, 2011
    Location:
    Fatima
  3. Zcott macrumors 68020

    Joined:
    Oct 18, 2009
    Location:
    Belfast, Ireland
    #3
    Yes. Set your iMessage caller ID to your email address on both devices.
     
  4. aarmstrong27 macrumors regular

    Joined:
    Jun 20, 2012
    #4
    Or set them both to your mobile number. Either way will work.
     
  5. Italianblend thread starter macrumors 68000

    Italianblend

    Joined:
    Mar 21, 2011
    Location:
    Fatima
    #5
    Thanks, but I don't see how to set the phone number on the iPad. It just lists "add another email"
     
  6. aarmstrong27 macrumors regular

    Joined:
    Jun 20, 2012
    #6
    I assume you have iOS 6 on both. If so:

    Verify your mobile number is associated with your Apple ID at applied.apple.com under Phone Numbers. If it isn't, then add it.
    LOG OUT of iMessage on your iPhone and iPad (Don't just turn off, actually log out).
    Log back in on your iPhone.
    Log back in on your iPad.
    At this time, it should register your phone number on your iPad and you will be able to select it.
     
  7. mrtune macrumors 6502a

    Joined:
    Jun 23, 2007
    #7
    Both devices need to be updated to iOS 6.

    On your phone turn off imessage, then turn it back on. Then go into the send and receive menu. It should show you that you can be reached from both phone number and email. I set mine to my phone number for both.

    Then on ipad, turn off imessage and turn back on. Once it activates, go into the send and receive menu and it should have your phone number and email address in the list it responds to. Set your phone number in the area where it asks how you want to start new conversations from.

    Also, imessage keeps different conversation lists for email and [hone numbers. You may have to start a new conversation with her for. The old conversation may be using your email as the reference while your phone uses the phone number. On her device that's two different people, hence two conversations on her end.

    I had this same issue.

    If all else fails, go to https://supportprofile.apple.com or http://appleid.apple.com and log in with the itunes account your imessage is logged into. Add your phone number in the mobile phone number area (it may be blank). Then repeat the steps above.
     
  8. parish macrumors 65816

    parish

    Joined:
    Apr 14, 2009
    Location:
    Wilts., UK
    #8
    Typo - should be appleid.apple.com
     
  9. Italianblend thread starter macrumors 68000

    Italianblend

    Joined:
    Mar 21, 2011
    Location:
    Fatima
    #9
    Ohh. Thanks everyone. I haven't updated my iPhone yet to 6. I want google maps! But thanks for the info.
     
  10. aarmstrong27 macrumors regular

    Joined:
    Jun 20, 2012
    #10
    thanks! Dang auto-correct!
     
  11. parish macrumors 65816

    parish

    Joined:
    Apr 14, 2009
    Location:
    Wilts., UK
    #11
    Thought that's what it might be :)
     

Share This Page