iMessage question

Discussion in 'iPhone Tips, Help and Troubleshooting' started by sherwooddavid, Jun 21, 2013.

  1. sherwooddavid macrumors newbie

    Joined:
    Feb 16, 2013
    #1
    Hello,

    My wife and I were using imessage with no problem here in Canada until I took a trip to the US.
    When I crossed the US border I put a T-Mobile sim card in my unlocked iphone 5 and and everything was green after that...basically no more imessages. My T-Mobile daily plan has unlimited data.
    My data roaming was turned off and someone told me that it should have been turned on ??
    I'm home now and facing a a bunch of charges for international texting and just wondering if I did wrong and why the imessage didn't work while I was in the US.:confused:

    Thanks,Dave
     
  2. nightstalkerz macrumors 6502

    Joined:
    May 9, 2013
    #2
    You need to have a wifi or data connection to use iMessage.

    When you turned off data roaming, your data connection was disabled so you it defaults to sending text messages.

    You can stop iMessage sending as text in settings > messages > send as SMS although it probably won't do you much good now.
     
  3. sherwooddavid thread starter macrumors newbie

    Joined:
    Feb 16, 2013
    #3
    Thanks a lot for the reply,I'll know better next time and leave the data roaming turned on and hopefully the imessage will work. Thanks again !
     
  4. dictoresno macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #4
    do me a favor and let me know if your imessages work again once you return to your original SIM card. i just had an issue when i was in iceland and using a local prepaid SIM. everything, including imessage, worked perfectly. however when i put my verizon SIM back in, i couldnt get imessage to work again, as it was stuck at "waiting for activation". i ended up having to restore.
     

Share This Page