imessage question

Discussion in 'iOS 8' started by GIZBUG, Jan 28, 2015.

  1. GIZBUG macrumors 65816

    GIZBUG

    Joined:
    Oct 28, 2006
    Location:
    Chicago, IL
    #1
    I've noticed most of the time, I get imessages from my wife's cell #. However, sometimes they come from her email, or her icloud.com account (and the message isn't sent showing her phone number)

    Recently, she said the same was happening from me when I imessage her (ie. shows my imessage came from generic_name@icloud.com)

    Why is this, and how to I make it so it is always coming and receiving from my #?
     
  2. Natzoo macrumors 65816

    Natzoo

    Joined:
    Sep 16, 2014
    Location:
    Not sure where i am
    #2
    your apple id is synced on both phones, and messages is turned on. this used to happen to me
     
  3. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #3
    Go in to iMessage settings on both phones and deselect the email addresses in the "Send & Receive" section so only the phone number is checked.

    It seems to be an iOS 7 and iOS 8 bug. Happens every now and again with me, my wife, my kids and my parents, and I've seen it posted elsewhere many times. iMessage sometimes for whatever reason forgets what it should be sending as. Very annoying.
     
  4. Agent-P macrumors 68030

    Agent-P

    Joined:
    Dec 5, 2009
    Location:
    The Tri-State Area
    #4
    I used to have this problem too and the above solution fixed it for me. As long as only the phone number is checkmarked you should be good.
     

Share This Page