iMessage questions

Discussion in 'iOS 6' started by creativedogmedia, Oct 17, 2012.

  1. creativedogmedia macrumors 65816

    creativedogmedia

    Joined:
    Jun 26, 2011
    #1
    Have a buddy who every time he would switch from his MBP and his iPhone it would show up in 1 of 2 windows on my device (so I'd have two open windows with his name on them).....I put him through the "how to make sure iMessage is integrated with your Mac and your iPhone/iPad" but now his messages are showing up from his email address and not his phone number. How do I fix this?

    Separately, my daughter is about to get a new iPod Touch. Until now, she has been on my wife's iTunes account. If she is going to use iMessage (my wife currently uses it) will she be able to do that under my wife's account or will she have to get her own Apple ID?
     
  2. AlphaVictor87 macrumors 6502a

    AlphaVictor87

    Joined:
    Sep 7, 2011
    Location:
    Saint Louis, MO
    #2
    Not sure about the first question sorry OP, i don't have a mac.

    But for this one, i would VERY MUCH suggest getting a separate Apple ID. I don't even own a mac, but i'm as far as everyone i know goes, am their Apple Guru who knows everything at least as far as iOS is concerned since i've had an iPhone longer than any of them. There are at least 6 people i know who share an apple ID and almost every time they have an issue i say "well you should probably get separate Apple ID's but since you won't i'll see what i can do..."
     
  3. whohasaquestion macrumors 6502

    Joined:
    Sep 17, 2011
    #3
    I have issue with iMessage on mac as well. The recipient sees my email address instead of phone number in the "from" field. Not a huge issue...an annoyance nonetheless.
     
  4. Tiptizzle macrumors 6502

    Joined:
    Apr 22, 2011
    #4
    Are his email address and phone number unified? Check the settings on he mac. If his phone number is not showing up on his mac, turn off imessage on both devices and turn it back on, then he should choose to send from his phone number on his mac.

    ----------

    Go to messages, click messages on the menu bar, click preferences, click accounts. Choose your apple ID. Is your phone number listed under "You can be reached at?" Make sure it's checked. Make sure "start new messages from" drop box has your phone number.
     

Share This Page