iMessage - send message using wireless keyboard

matttye

macrumors 601
Original poster
Mar 25, 2009
4,953
30
Lincoln, England
Hiya,

Does anybody know if there's a way to send a message using the Apple wireless keyboard without having to tap "send" on the iPad itself?

The keyboard was listed in the iPad accessories section of the Apple website but appears to be a Mac keyboard. :confused:

Thanks :)
 

iP4S-Zak

macrumors newbie
Apr 7, 2012
8
0
Have you tried the Mac wireless keyboard. I have used it for notes and stuff but never tried messages?
 

matttye

macrumors 601
Original poster
Mar 25, 2009
4,953
30
Lincoln, England
Have you tried the Mac wireless keyboard. I have used it for notes and stuff but never tried messages?
That's the keyboard I have. Pressing return simply enters a new line and doesn't send the message.

I can live with it but would prefer a way to send the message using the keyboard.
 

Conan86

macrumors 6502
Apr 9, 2012
326
137
Singapore
The keyboard listed as iPad accessory is indeed the Mac wireless keyboard, and I don't think they've put in a shortcut for "Send" yet, which is kinda wasted
 

matttye

macrumors 601
Original poster
Mar 25, 2009
4,953
30
Lincoln, England
The keyboard listed as iPad accessory is indeed the Mac wireless keyboard, and I don't think they've put in a shortcut for "Send" yet, which is kinda wasted
That's what I thought, I've tried every combination of fn/ctrl/shift/alt+return I can think of and nothing works.

Hopefully they'll add this in iOS6 or before then. It seems crazy that you have to touch the screen to send a message.

Thanks :)
 

BigMcGuire

Contributor
Jan 10, 2012
4,612
5,662
California
That's what I thought, I've tried every combination of fn/ctrl/shift/alt+return I can think of and nothing works.

Hopefully they'll add this in iOS6 or before then. It seems crazy that you have to touch the screen to send a message.

Thanks :)
Yep. Add me to the "WTF?!" boat. I can't believe I have to reach over and hit send on the iPad 3 every time I type out a message on my bluetooth keyboard. Oh well. lol.
 

maiphuhung

macrumors newbie
Jun 22, 2015
2
0
Ho Chi Minh, Vietnam
On you iDevies. Go into "Settings" then navigate to "General", go to "Keyboard" option. Select the "International Keyboards" option and change your "Hardware Keyboard layout" from "U.S." to "U.S.International-PC". Your RETURN/ENTER Key will now send messages on you messaging Apps.
 

IrishVixen

macrumors 68020
Jun 20, 2010
2,487
96
On you iDevies. Go into "Settings" then navigate to "General", go to "Keyboard" option. Select the "International Keyboards" option and change your "Hardware Keyboard layout" from "U.S." to "U.S.International-PC". Your RETURN/ENTER Key will now send messages on you messaging Apps.
Interesting--no such luck here with a Logitech keyboard. Still doesn't send messages in the stock Messages app when you hit Enter or any combination of keys + Enter.