iMessage sending from email address not phone number

Discussion in 'Apple Watch' started by adenbeckitt, Apr 26, 2015.

  1. adenbeckitt macrumors member

    Joined:
    Jun 23, 2010
    #1
    Hey guys,

    Is there a setting somewhere that I can't find regarding which "address" to start/reply to iMessages from?

    I've managed to make it use the number by unselecting all the other addresses in my (phone) Settings app under the 'You can be reached by iMessage at". However, if I reselect the email addresses then it always sends from my Apple ID address.
     
  2. mattopotamus macrumors G4

    mattopotamus

    Joined:
    Jun 12, 2012
    #2
    In your phone go to settings messages, send and receive. Set start new conversation to your phone number.
     
  3. adenbeckitt thread starter macrumors member

    Joined:
    Jun 23, 2010
    #3
    It was actually already set to that, and is so on all my other devices too.
     
  4. skaclown macrumors member

    Joined:
    Feb 2, 2008
    #4
    Same issue here, I don't see any way of selecting the default "Send message from" on the watch...
     
  5. sb22 macrumors 6502

    sb22

    Joined:
    Aug 14, 2012
    #5
    mine hopped from phone to email last night, fine by me but i do wonder why
     
  6. Munky macrumors 6502

    Joined:
    Apr 27, 2011
    #6
    turn off iMessage then turn it back on. I had the same problem but its gone now.
     
  7. adenbeckitt thread starter macrumors member

    Joined:
    Jun 23, 2010
    #7
    Worked :D
     

Share This Page