iMessage sending from strange phone number

Discussion in 'iPhone Tips, Help and Troubleshooting' started by mbaker23, Sep 19, 2013.

  1. mbaker23 macrumors newbie

    Joined:
    Sep 19, 2013
    #1
    Hello. I recently upgraded my iPhone 5 to iOS 7, and since then my iMessages are being sent from a strange phone number that isn't mine. I've never had this problem in the past. My actual phone number won't show up as an option in the "Send & Receive" list for Messages. I have Sprint as my carrier if that makes a difference. Thank you for any help in this matter.

    -Mitch
     
  2. atrainR macrumors newbie

    Joined:
    Sep 20, 2013
    #2
    Mitch, I have the same exact problem! I also have Sprint and soon after I upgraded to iOS 7, my iMessages have been sent thru a weird number which I found to be the last 7 digits of my ICCID number(settings>general>about). This is very strange, I even called sprint so they could give me help and the just forwarded me to Apple which ended up ending my call without me speaking to anyone...such a mess, any luck yet??
     
  3. jdaniel macrumors 65816

    Joined:
    Mar 21, 2009
    Location:
    Ottawa, Canada
    #3
    is sprint cdma? just disable imessage, re-set network settings.. hard reset the phone then enable again and see if it fixes it. thats the usual trouble shooting..
     
  4. mbaker23 thread starter macrumors newbie

    Joined:
    Sep 19, 2013
    #4
    Thank you so much for responding, but I'm still having no luck! I tried re-setting my network settings with a hard re-set of my phone, and my iMessage still wants to send from that strange number. (**I think you might be right atrainR, it does seem to be part of my ICCID number.)

    Also, from what I understand, Sprint is cdma. Anymore advice? :confused:
     
  5. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #5
    Turn iMessage off

    Reboot phone

    Turn iMessage on (wait for it to validate)

    Check send receive settings
     
  6. mbaker23 thread starter macrumors newbie

    Joined:
    Sep 19, 2013
    #6
    Turning off iMessage and re-setting my phone isn't working. My phone number still won't even show up as an option.

    [​IMG]

    (That second blacked-out row is my email address.)
     
  7. atrainR macrumors newbie

    Joined:
    Sep 20, 2013
    #7
    Honestly, looks like we might have gotten a glitch in the update or just defected phones...my insurance replaces it for free so I'm thinking that getting a new phone is my only option.
     
  8. jdaniel macrumors 65816

    Joined:
    Mar 21, 2009
    Location:
    Ottawa, Canada
    #8
    Or restore the phone and start new
     
  9. mbaker23 thread starter macrumors newbie

    Joined:
    Sep 19, 2013
    #9
    I did a complete restore of my phone, and it fixed the problem! Thank you so much for all the help :)
     
  10. jdaniel macrumors 65816

    Joined:
    Mar 21, 2009
    Location:
    Ottawa, Canada
    #10
    Good ! That usually solves problems just a pita
     

Share This Page