iPhone iMessage sends over data when connected to wifi?

Discussion in 'iOS 6' started by Woomy123, Feb 22, 2013.

  1. Woomy123 macrumors regular

    Joined:
    May 12, 2009
    #1
    There is probably already a thread for this but I can't find it.

    So basically when I have data switched on and I am connected to wifi my iPhone will still send stuff over my data connection instead of wifi, I know this because I reset my usage and send stuff over iMessage and the usage goes up not by much but it still goes up, if I turn data off and send it again the usage doesn't go up and it send stuff much quicker, my issue is I don't always have 3G on because it uses to much battery and when I go home I don't have 3G in my area so I rely on my home wifi, so Im left with the little 'o' symbol and that is no good for sending images even if I am connected to wifi, so will apple ever sort this issue out? Is there something I can do to make it send over wifi even with data on? Is there a jailbreak tweak that changes the settings to prefer wifi over 3G?
     
  2. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #2
    As far as I can tell, iMessage always goes over wifi for me when I'm on wifi. I can call because incoming messages hit my non-cellular iPad at the same time as they hit my iPhone. And there's one place where I frequent that has really piss-poor cell service (the building is like a Farady cage), but I still can send/receive iMessages because I'm on wifi when I'm there.
     
  3. Woomy123 thread starter macrumors regular

    Joined:
    May 12, 2009
    #3
    Reset your network usage then connect to wifi and send an iMessage, make sure your data is on as well and then go back to usage and see if it has gone back up?
     
  4. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #4
    I do not need to. Like I said, I receive iMessages even when I do not have cell service (like on my iPad).
     
  5. Dented macrumors 6502a

    Joined:
    Oct 16, 2009
    #5
    I can back up what the second poster is saying, iMessage always uses wifi when it's available for me. It's obvious because pictures are sent much, much quicker than they would be over the phones local data connection. This has always been the way iMessage has behaved for me, I don't think there's any preference to set because that's the way it's designed - like the rest of iOS, wifi is always first choice.

    The only thing I can think of that might override that in iMessage is perhaps some crazy carrier setting?
     
  6. dirkyd3rk macrumors newbie

    dirkyd3rk

    Joined:
    Jan 20, 2012
    Location:
    Houston
    #6
    iMessage is a way for carriers to always charge you for data (thanks apple)
     
  7. bozzykid macrumors 68020

    Joined:
    Aug 11, 2009
    #7
    Huh? You don't have to use iMessage. And using an iPhone basically means you will always need a data plan.
     
  8. Dented macrumors 6502a

    Joined:
    Oct 16, 2009
    #8
    iMessage is a way to seamlessly replace expensive picture messaging over MMS with something which is entirely free over wifi and effectively free on most people's data plans so no, I don't think it's exactly a major blessing for the networks. I think to be honest they'd be happier if iMessage and similar didn't exist at all..
     
  9. ihasiphone macrumors newbie

    Joined:
    Jun 27, 2010
    #9
    Anandtech's analysis of iMessage says that it prefers cellular networks to wifi for security reasons. Texts prefer to go through cellular data and larger things like pictures go through wifi when available.
     
  10. FSMBP macrumors 68020

    FSMBP

    Joined:
    Jan 22, 2009
    #10
    ihasiPhone is right. iPhone's iMessage prefers 3G over Wifi for text iMessages. However, for pictures/video/audio, it prefers Wifi. See this previous MacRumors thread which discusses this and provides the source:

    http://forums.macrumors.com/showthread.php?t=1481106
     
  11. dextr3k macrumors 6502

    Joined:
    Nov 26, 2012
    #11
    I didn't know about the preferences, that is interesting to know.
     
  12. quietstormSD macrumors 6502a

    quietstormSD

    Joined:
    Mar 2, 2010
    Location:
    San Diego, CA
    #12
    You just might have a weak wifi signal, that it's switching over to data when trying to send the message.
     

Share This Page