iMessage stopped working yesterday

Discussion in 'iOS 7' started by fergusor, Sep 22, 2013.

  1. fergusor macrumors member

    Jun 18, 2009
    Hi guys,

    I'm having problems with iMessaging on my iPhone.

    I updated to iOS7 on Wednesday and everything was fine. But yesterday my iMessaging stopped working after I changed my Apple ID password.

    Now my iPhone is saying 'Waiting for activation...' when I try and switch iMessaging back on and I keep getting a text message from +44 7786 205094 full of random characters.

    Anyone else having a similar problem and managed to fix the issue? I've tried restoring, setting up as a new phone, all sorts but it just won't come back on.

  2. vasili0s macrumors member

    Nov 19, 2012
    known issue after the iOS7 release. follow the applicable steps in this article:

    if a no go contact apple so they can forward the issue.
  3. fergusor thread starter macrumors member

    Jun 18, 2009
    Tried every step in there and still not working.

    Just spoken to Apple support and they've told me to leave it activating for 24 hours and call back if still not working. Apparently every time I switch iMessaging off it's starting the activation process again.

    I'll leave it 24 hours and see what happens.
  4. London Lad macrumors member

    Nov 12, 2010
    If you are an o2 customer and have ever installed Tu-Go then that is the problem.

    Delete your Tu-Go account from within the Tu-Go app then delete the app.

    Turn Imessage and face-time off then back on and they should both activate within a couple of mins. You can then reinstall Tu-Go and recreate your account.

    The txt you keep getting is the iMessahe activation txt but you should not be seeing it. When you have a Tu-Go account all your txt and voice calls go via Tu-Go servers and they are not handling the activation txts properly at the moment. You must delete your Tu-Go account and not just the app itself.
  5. fergusor thread starter macrumors member

    Jun 18, 2009
    Thank you so much, that was the problem!! This has been bugging me since yesterday and I've been getting more and more annoyed with it.

    Won't be using that app again!!!!!!

    Thanks again.

Share This Page