iMessage stuck on "Sending"

Discussion in 'iOS 8' started by Bkosher84, Dec 2, 2014.

  1. Bkosher84 macrumors member

    Joined:
    Sep 16, 2014
    #1
    Okay, so I have a weird issue going on.. Over the holiday weekend I attempted to send my wife two pictures of a wedding we attended, but I was in a bad service area (T-Mobile) and it was taking forever to go through.. So I decided to delete the two messages I was attempting to send but now her iMessage is in a continuous "Sending" status even though every message after the two deleted have been going through just fine.

    So far all I have tried to do is delete the entire message string but that hasn't done anything, as when I started a new iMessage, it would have the "Sending" status.

    Anyone know how to fix this?
     
  2. eclipse01 macrumors 68020

    eclipse01

    Joined:
    May 16, 2011
    Location:
    Eau Claire, WI
    #2
    I have had this happen a couple of times (usually with super low signal, to none at all)

    usually a reboot will clear it
     
  3. Bkosher84 thread starter macrumors member

    Joined:
    Sep 16, 2014
    #3
    Haha, I guess the word of thumb should be if all else fails, restart, restart, restart. Thanks that did it!
     
  4. eclipse01 macrumors 68020

    eclipse01

    Joined:
    May 16, 2011
    Location:
    Eau Claire, WI
    #4
    yeah, I would think that airplane mode on/off would do the trick but it did not.
     
  5. Delorean2006 macrumors 6502a

    Joined:
    Feb 4, 2012
    #5
    I had this issue, what I noticed is that I didn't have, in messages, set to send as sms on turned on so that when the phone can't send the message as iMessage it would instead send the message as a text.
     

Share This Page