iMessage suddenly not activating on 6s Plus iOS 10 beta 2

Discussion in 'iOS 10' started by dsr2, Jul 14, 2016.

  1. dsr2 macrumors regular

    dsr2

    Joined:
    Aug 19, 2013
    #1
    I had to switch out my sim to a non iPhone for a few days. When I went to use the iPhone again, I could not get the iMessage to activate my phone number. I either get an error message or if I don't get the error message, the gear in front of my number just endlessly spins and the phone number remains greyed out. I've reported the bug to Apple, but I was just curious if anyone else has run across this and/or had a fix for it.

    Although it's really more of a minor annoyance which I am sure will eventually get straightened out, it does prevent me me from being about to access messages on my iPad. TIA

    Edited to add: I did dergister my number before I switched the sim so I assume there was no problem on that end going to a non-iPhone phone.
     
  2. blasto2236 macrumors 6502a

    Joined:
    Nov 4, 2012
    #2
    I had the same issue recently, after I changed my Apple ID password. This caused iMessage to re-authenticate I guess (FaceTime, too) and while my Apple ID emails were working, my phone # was "waiting for activation" and spinning in the send/receive menu.

    I tried all manner of general iMessage activation troubleshooting to solve it. In the end, restoring and setting up as new was the only way I found around the issue. Restoring from backup brought it back :/

    For the purposes of science, I'm using an iPhone 6s Plus on T-Mobile.
     
  3. dsr2 thread starter macrumors regular

    dsr2

    Joined:
    Aug 19, 2013
    #3
    Thanks for the reply. Have not changed my password and I also tried to wipe and set up as new from a backup. So far, nothing has worked but I will keep trying.
     
  4. bbrks macrumors 65816

    bbrks

    Joined:
    Dec 17, 2013
    #4
    Maybe there is a problem with your operator...you could try to ask them....
     
  5. H3LL5P4WN, Jul 15, 2016
    Last edited: Jul 15, 2016

    H3LL5P4WN macrumors 6502a

    H3LL5P4WN

    Joined:
    Jun 19, 2010
    Location:
    Pittsburgh PA
    #5
    I ran into this as well. I had to restore (to 10b2 or 9.3.2) to get it to work again.

    Currently back on 9.3.2.
     
  6. Simacca macrumors 6502a

    Simacca

    Joined:
    Jul 31, 2008
    Location:
    UK, South East.
    #6
    Funny thing is I got signed out of iMessage the other day for no reason and had to sign back in. Luckily it worked for me without restoring.
     
  7. blasto2236 macrumors 6502a

    Joined:
    Nov 4, 2012
    #7
    What do you mean by "set up as new from a backup"? Those two statements cancel each other out. If you're restoring from a backup after setting up as new, you are bringing the issue back along with the backup in a lot of cases.

    Also: I missed a step. I restored to 9.3.2, reinstalled the profile (went public instead of dev this time, if that helps), then updated to 10 again. This is all set up as a new iPhone. It worked for me, but YMMV.

    I should also note that after doing all this, I restored from an iTunes backup and it did bring the issue back along with it. Had to start all over and stay set up as new. It's a PITA to get everything set up again, but I'm kinda happier with a fresh install of 10 anyway from a usability standpoint.

    Just make sure all your contacts and photos are synced to iCloud before doing anything and it should only take an evening to get everything set up the way you like it again.
    --- Post Merged, Jul 15, 2016 ---
    In my case, I called T-Mobile and they were reporting no issues. Although I talked to someone experiencing the same issue on 9.3.2, so I don't know that it is necessarily specific to the 10 beta.
     
  8. bbrks macrumors 65816

    bbrks

    Joined:
    Dec 17, 2013
    #8
    Well than, if it isn't operators fault, than it's definitely a bug, after all it's a beta, right :)
     
  9. buckc macrumors newbie

    Joined:
    Jul 15, 2016
    #9
    I'm currently suffering from this problem, though I didn't just upgrade to the beta, I also upgraded to a new phone. I started with a new setup, iMessage wouldn't activate. So I restored from a backup, and it too wouldn't activate. If I stick my sim in my old phone, iMessage activates in about 2 minutes, though Facetime did not. Or at least I gave up waiting for it based on how long iMessage took. Turn off iMessage and Facetime on the old phone, and put the sim back into the new phone. I've tried Apple's Deregistration page, and it simply told me my phone number wasn't registered with iMessage. Since my old phone did activate rather quickly, I assume there is nothing wrong with my carrier, unless it's some kind of caching thing on their end that favoured the old phone.

    I've tried everything people have recommended:

    -Reset -> Network
    -Time Zone to Auto and is correct.
    -Location services are on
    -Region is correct.
    -I've tried a New setup
    -I've tried a Restore backup
    -I tried to deregistered my phone number with iMessage servers, it told me my phone wasn't registered (so turning it off on the old phone was successful)
    -I didn't have an Apple Id associated with the phone, so there's nothing to log out of. I actually created one and logged in with the store, iCloud, iMessage, Facetime, but it made no difference either. Although now I can actually see my phone number in iMessage with the spinning disc for a bit, along with the Apple Id.

    Half the time iMessage complains an authentication error occurred when I enable iMessage, and the other it just tells me it's trying to authenticate. I wish it would give me a more meaning full error on why the authentication failed.

    I've spent almost 8 hours on this now, with no success. A common thread seems to be just to leave it alone overnight and a lot of people wake up to it working.

    Failing that, my only unexplored option is to downgrade and see if this phone actually even works in iOS 9. I never even tried that. I went straight to the beta to start getting used to it.
     
  10. dsr2 thread starter macrumors regular

    dsr2

    Joined:
    Aug 19, 2013
    #10
    Thanks for all the replies. I would switch back to 9.3.2 if I knew how. Also I was under the impression you could not go back
     
  11. BullittMustang macrumors 6502a

    Joined:
    Mar 27, 2008
    #11
    You can restore to 9.3.2 in iTunes. That's what I had to do. Then I activated iMessage, made sure it worked, then reinstalled iOS10. Works fine now.
     
  12. M5RahuL macrumors 68020

    M5RahuL

    Joined:
    Aug 1, 2009
    Location:
    Colorado
    #12
    You sure can. Here's how ( typing on my phone so plz excuse the structure )
    Download the latest released iOS version from Apple, and start iTunes.
    Turn off ' Find my iPhone ' under Settings, General..to make things easier after restore.
    Place the device in Recovery Mode ( power device off, while holding down the home button, connect the device to your computer. Keep the home button depressed till you see an usb image on the phone..now let go of the home button)
    Hold down the Option button (mac) and click on 'restore device'.
    Navigate to where you downloaded the ispw file (iOS that you downloaded from Apple), select it and let it fly!

    Sit tight, and let it do it's thing...Should take about 7-10 mins iirc.

    Restore from backup ( must choose backup from iOS 9.x ... this will be indicated during set up ) or set up as new device.

    Hope that helps
     
  13. Jaymdee macrumors newbie

    Joined:
    Sep 23, 2012
    #13
    I just went through the same thing. iPhone 6s and 6splus. I had to restore phones three times before everything worked.
     
  14. dsr2 thread starter macrumors regular

    dsr2

    Joined:
    Aug 19, 2013
    #14
    Just a quick update: Because I really can't control myself, I figured I'd download the next beta version of the 10 before I attempted to go back to 9 and lo and behold, iMessage now works for me and added my phone number! Don't know long term how it behave, but I am taking your advice and teaching myself how to go back to 9 in case something else goes awry! Thanks for all the advice.
     

Share This Page